
 

  

 

 

 

 

River2D 
 

 

２次元水深平均河川流体力学・魚類生息場モデル 

 

 

水深平均モデリング概要・ユーザーズマニュアル 
 

 

 

 

 

 

 

 

Peter Steffler and Julia Blackburn 
University of Alberta 

September, 2002 
 

監訳 関根雅彦、朝位孝二 
山口大学 

２００６年９月 
 

山口県 
 



 

  



 

 i 

目次 

1.0 水深方向平均モデリングの概要..............................................................................................1 

1.1 概説 ...........................................................................................................................................1 

1.2 水深方向平均モデル................................................................................................................1 

1.3 必要なデータ ...........................................................................................................................2 

2.0 ２D 流体力学モデリングの原理..............................................................................................4 

2.1 物理的な公式化........................................................................................................................4 

2.1.1 質量保存 ............................................................................................................................4 

2.1.2 運動量の保存.....................................................................................................................6 

2.2 水深方向平均流れ方程式の数値モデリング........................................................................9 

2.2.1 有限要素法.......................................................................................................................10 

2.2.2 離散化誤差.......................................................................................................................12 

2.2.3 解法 ..................................................................................................................................13 

3.0 River2D モデル解説.................................................................................................................15 

3.1 概要 .....................................................................................................................................15 

3.2 謝辞 .....................................................................................................................................15 

3.3 利用条件 .............................................................................................................................15 

4.0 定式化 .......................................................................................................................................16 

4.1 概要 .........................................................................................................................................16 

4.2 流体力学モデル......................................................................................................................16 

4.2.1 基本的な仮定...................................................................................................................17 

4.2.2 河床抵抗モデル...............................................................................................................17 

4.2.3 横剪断モデル...................................................................................................................19 

4.2.4 干出・冠水領域の処理...................................................................................................19 

4.3 単純な氷カバー・モデル......................................................................................................20 

4.3.1 氷と河床抵抗が共存する場合のモデル化...................................................................22 

4.4 魚類生息場モデル..................................................................................................................23 

4.5 境界抽出モジュール..............................................................................................................24 

4.6 流体力学のモデル実装..........................................................................................................28 

4.6.1 有限要素法.......................................................................................................................28 

4.6.2 Newton Raphson 法 ...........................................................................................................29 

4.7 モデル方程式解法..................................................................................................................30 

4.7.1 直接解法 ..........................................................................................................................30 

4.7.2 反復解法 ..........................................................................................................................31 



 

 ii 

5.0 使用法 .......................................................................................................................................34 

5.1 インストール、.......................................................................................................................34 

5.1.1 モデルの必要条件...........................................................................................................34 

5.2 入力ファイルの準備..............................................................................................................34 

5.2.1 メッシュデータ－.cdg ファイル ...................................................................................34 

5.2.2 氷地形－.ice ファイル ....................................................................................................34 

5.2.3 河道指標－.chi ファイル................................................................................................35 

5.2.4 魚の選好性－ .prf ファイル ..........................................................................................35 

5.3 River2D を実行する................................................................................................................35 

5.4 標準の Windows 操作 ............................................................................................................37 

5.4.2 File -> New ........................................................................................................................37 

5.4.2 File -> Open .......................................................................................................................37 

5.4.3 File -> Save........................................................................................................................38 

5.4.4 File -> Save As...................................................................................................................38 

5.4.5 File -> Print ........................................................................................................................38 

5.4.6 File -> Print Preview..........................................................................................................38 

5.4.7 File -> Print Setup..............................................................................................................38 

5.4.8 File -> recent documents....................................................................................................38 

5.4.9 File -> Exit .........................................................................................................................39 

5.4.10 Edit...................................................................................................................................39 

5.4.11 View .................................................................................................................................39 

5.4.12 HELP ...............................................................................................................................39 

5.5 追加のファイル操作..............................................................................................................39 

5.5.1 File-> Save As EMF….......................................................................................................39 

5.5.2 File -> Compress Video… .................................................................................................39 

5.6 ディスプレイ操作...................................................................................................................40 

5.6.1 Display -> Redraw .............................................................................................................41 

5.6.2 Display -> Scale to Fit .......................................................................................................42 

5.6.3 Display -> Zoom In On Rectangle.....................................................................................42 

5.6.4 Display -> Zoom In On Point ............................................................................................42 

5.6.5 Display -> Zoom Out .........................................................................................................42 

5.6.6 Display -> Move Center to Point .......................................................................................42 

5.6.7 Display -> Mesh.................................................................................................................43 

5.6.8 Display -> Node Numbers .................................................................................................43 

5.6.9 Display -> Water's Edge.....................................................................................................44 

5.6.10 Display -> Contour/Colour ..............................................................................................45 



 

 iii 

5.6.11 Display -> Vector .............................................................................................................47 

5.6.12 Display-> Bed Contours ..................................................................................................49 

5.6.13 Display -> Annotation......................................................................................................49 

5.6.14 Display -> Dump nodal csv file .......................................................................................50 

5.6.15 Display -> Dump grid csv file..........................................................................................51 

5.6.16 Display -> Extract points to csv file.................................................................................51 

5.6.17 Display -> Extract section to csv file ...............................................................................51 

5.7 流体力学モデルの操作..........................................................................................................52 

5.7.1 定常モードの解析課程...................................................................................................52 

5.7.2 非定常モードの解析課程...............................................................................................53 

5.7.3 Flow -> Run Steady ...........................................................................................................55 

5.7.4 Flow -> Run Transient .......................................................................................................58 

5.7.5 Flow Boundaries ................................................................................................................61 

5.7.6 Flow -> Edit Flow Boundary .............................................................................................61 

5.7.7 Flow -> Define New Flow Boundary ................................................................................65 

5.7.8 Flow -> Reset Initial Conditions........................................................................................65 

5.7.9 Flow -> Check Memory.....................................................................................................66 

5.7.10 Flow -> Cumulative Discharge ........................................................................................67 

5.8 メッシュ編集オプション......................................................................................................69 

5.8.1 Mesh Edit->Load Bed File….............................................................................................69 

5.8.2 Mesh Edit->Extract Boundary… .......................................................................................70 

5.8.3 Mesh Edit->Mesh Merge ...................................................................................................72 

5.8.4 Mesh Edit->Add Floating Node.........................................................................................73 

5.8.5 Mesh Edit->Region Refine ................................................................................................73 

5.8.6 Mesh Edit->Auto Refine....................................................................................................75 

5.8.7 Mesh Edit->Delete Floating Node .....................................................................................76 

5.8.8 Mesh Edit->Clear Untriangulated Nodes...........................................................................76 

5.8.9 Mesh Edit->Triangulate .....................................................................................................76 

5.8.10 Mesh Edit->Smooth .........................................................................................................76 

5.8.11 Mesh Edit->Mesh Information….....................................................................................77 

5.9 生息場分析 .............................................................................................................................77 

5.9.1 Habitat -> Preference .........................................................................................................78 

5.9.2 Habitat -> Channel Index...................................................................................................79 

5.9.3 Habitat -> Weighted Usable Area ......................................................................................80 

5.9.4 Habitat -> Save Node Attribute File ..................................................................................80 

5.9.5 Habitat -> Save Physical Attributes ...................................................................................81 



 

 iv 

5.10 結氷の操作 ...........................................................................................................................81 

5.10.1 Ice Cover-> Load Ice File ................................................................................................81 

5.10.2 Ice Cover -> Remove Ice .................................................................................................82 

5.11 オプション設定操作............................................................................................................82 

5.11.1 Options -> Habitat Options ..............................................................................................83 

5.11.2 Options->Mesh Edit Options ...........................................................................................83 

5.11.3 Options->Flow Options....................................................................................................84 

5.11.4 Options->Solver Options .................................................................................................86 

5.11.5 Options -> Transient Output Options ...............................................................................87 

5.11.6 Options->Ice Options .......................................................................................................90 

6.0 参考文献 ...................................................................................................................................92 

 



 

 1 

1.0 水深方向平均モデリングの概要 

1.1 概説 

パソコン能力と計算のソフトウェア技術の進歩により、工学のほとんどすべての

分科で詳細な分析が日常的なものとなっている。水路・河川工学において、二次

元（2D）水深平均モデルは通常の実務において一次元モデルを統合し始めている。

これらのモデルは、流速と水深の局所的な分布を詳細に知ることが重要な研究に

おいて役立つ。例えば、橋の設計、河川改修と分流、汚染物質輸送解析、そして

魚類生息場評価などである。この解説は 2D 河川モデリングについて概説すること

を目的としている。そして、実用的なアプリケーションに対して考慮すべき問題

についてハイライトを当てる。 

高流速と急勾配、そして比較的浅い水深が発生する可能性のある河川のモデルの

構築は、特に困難な数値計算に関するチャレンジである。この事実は、おそらく

沿岸域や感潮部に比べて河川での浅水モデルの適用が遅れている重要な要因と思

われる。しかし最近になって、本来亜音速の流体力学問題のために開発された計

算技術がうまく適用されるようになってきた。これらの技術（衝撃波獲得法また

は高解像度スキームと呼ばれる）は、人工渦粘性係数の導入なしで、常流と射流

が混在した流れ場の計算を可能にした。河川技術者にとって肝心な点は、疑念が

少なくて，信頼のおける精度の良い解の入手である。 

通常，2D 河川モデル・アプリケーションは水路の比較的限られた範囲（主に水路

幅の１０倍程度以下の長さの範囲）に着目している。ほとんどの場合、流量変動

は区間の滞留時間と比べると小さく、定常状態が仮定できる。しかし、大部分の

モデルは非定常計算の瞬間値を与えるようになっており、定常解は長時間計算し

た後の漸近的遷移解として得られることが多い。 

1.2 水深方向平均モデル 

多くの商業的、あるいはフリーで利用できる 2D モデルが存在する。それらはいろ

いろな計算スキームに基づいており、グラフィカルなプリプロセッサ、ポストプ

ロセッサを提供している。しかし、基礎をなす物理学は、多かれ少なかれ、共通

である。全ての 2D モデルは、基本的な物質量保存則と水平２方向の運動量保存則

を解く。モデルからの出力は、各計算点あるいは接点における水平 2 方向の速度

と水深である。垂直速度分布は均一、圧力分布は静水圧であると仮定される。湾

曲水路における二次流のような重要な三次元効果は、含まれない。経験則として、

水面幅が水深の１０倍以下であるような状況のモデル化では三次元効果について

注意しておく必要がある。 
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多くの問題において、横断方向に水が存在する範囲を計算前に知ることはできな

い。実際、氾濫原マッピング問題では、これ自体が計算によって知りたい結果で

ある。既存の 2D モデルでは、この冠水するかしないかという問題を扱うのにいく

つものアプローチをとっている。一部のモデルでは、最小水深に閾値を設定して

セルまたは要素をオン／オフし、流れのない境界を挿入している。他のモデルで

は、水深が非常に浅い部分では、非常に薄い水の層が常に存在するように流体の

特性を変更する。また別のモデルでは、水路床上および干上がった地面の下で、

通常の自由水表面が計算されるように地下水流方程式を組み合わせている。（水が

存在するところでは自由水表面、水が存在しないところでは地下水面を計算す

る。） 

2 次元モデルスキームとしては、有限差分法、有限体積法、有限要素法が利用可能

である。これらのアプローチはそれぞれ利点と欠点を持つ。いささか単純に論じ

すぎているきらいはあるが、著者は有限体積法がもっとも安定で効率的であり、

一方、有限要素法はもっとも柔軟に地形を表現できると考える。 

1.3 必要なデータ 

モデルは入力データが命であるといわれるが、その通りである。入力データとし

て、2D 流体力学モデルは、水路・河床地形、粗度と水平方向渦粘性分布、境界条

件、初期流況条件を必要とする。それに加えて、何らかの離散メッシュまたはグ

リッドが、流れの変化を表現できるように設計されていなければならない。 

河床地形を正確に再現することは、おそらく 2D モデルの実行上最も重要で難しく

時間がかかる作業である。単純な横断面測量は、一般に言って不十分である。大

きな河川では GPS と音響探深システムの組み合わせ、小さい河川では分散型トー

タルステーション測量が効果的であることが知られている。いずれにしても、1 調

査サイトにつき最低１週間は現地資料収集にかかると思わなければならない。現

地データは、2D モデルに入力する前に、良質なデジタル地形モデルによって処理

され、チェックされなければならない。 

河床粗度は（粗度高さ、またはマニングの粗度係数 n の形式）重要度は低い。多

くの二次元的効果が抵抗係数に組み込まれる従来の一次元のモデルと比較して、

二次元の抵抗項は直接の河床剪断だけに関係する。河床材料とその粒径を観察す

るだけで、通常合理的な初期のい粗度評価を与えるには十分である。観察された

水面高への調整を通じて最終的な値を定めればよい。非現実的な粗度値なったと

すれば、それは河床地形に問題があると考えられる。 

水平渦粘性分布は、有限差分モデルや有限要素モデルの安定性にとって重要で、
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しばしば非現実的に大きい値を割り当てる必要がある。また実測された流れ分布

に合わせるための調整係数として使うことがありえる。安定した衝撃波獲得法と

高解像度計算スキームは、これらの値に敏感ではない。正確な渦粘性の決定が必

要であるケースでは、採用している乱流モデルについて考慮しなければならない。 

境界条件は通常流入部においては総流量を、流出部においては一定の水面高ある

いは水位流量曲線の形式をとる。2D モデルは流れの方向や大きさについて暗黙の

仮定を置かないので、水路分流部での流量配分や流入流量、流出水面高は直接計

算することができる。流れの境界条件を対象としている領域から距離をおいて設

置することは、境界条件の不確実性の影響を最小にするために大切である。初期

条件は大切である。なぜなら、定常流計算であっても、繰り返し計算において初

期条件は初期値として用いるからである。初期条件を適切に設定できれば、計算

実行時間は大幅に減少する。また、結果が安定するか発散するかすら左右する。 

メッシュや格子形状は、2D モデリングにおける魔術的な部分である。自由度（計

算節点の数と一節点当たりの 3 つの未知数の積）の総数は、利用可能なコンピュ

ータ容量と時間に制限される。最新の PC を一晩中で走らせれば、100,000 オーダ

ーの節点を使った計算が可能である。問題は、目的に見合った最も正確な解が得

られるようにいかにこの節点を配置するか、である。計算上注目する場所や流速

の変化が大きい場所での高密度の節点配置、節点間隔のなめらかな変化、そして

要素やセル形状の規則性などは、十分配慮すべき事項である。おおまかな経験則

としては、流れ場の形状を信頼できる分解能で表現すために各方向に対して最低

でも 4、できれば 10 以上のセルまたは要素が必要である。最終的な解に与えるメ

ッシュ・デザインの影響に関する疑問を払拭するためには、複数のメッシュ・デ

ザインを用いて結果を比較することが必要になる。幸い、メッシュ・デザインの

助けになるグラフィック・プリプロセッサが利用可能である。またこれは、後に

計算結果の解釈にも利用できる。残念なことに、これらのプリプロセッサにはよ

り多くのプログラミング努力が必要であり、しばしば 2D 流体力学モデル自体より

も高価である。 
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2.0 ２D 流体力学モデリングの原理 

本節では、2D水深平均 2D流体力学モデルの物理学上での簡潔な背景を提供する。

この背景を知ることは、入力パラメータの重要性を知り、モデル結果の限界と期

待される信頼性を理解する助けとなる。 

たいがいのコンピュータモデルには 2 つのレベルの近似が内包されていること、

そして、マーフィの法則によれば、その２つのレベルの誤差は交じり合って現れ

ることを理解することが重要である。近似の第一のレベルは、物理的な現実を数

式に抽象化する段階にある。このレベルで、我々は最も大事な部分に焦点をあて

るため、その他の多くの部分を省いている。我々が焦点をあてた現実のこの限ら

れた部分集合でさえ、我々は必ずしも完全にその挙動を理解しているわけではな

い。乱流は、その古典的な例である。 

近似の第二のレベルは、数学的表現をコンピュータ計算に変換する部分にある。

ここでの本質的問題は、我々の数学が現実空間が無限の点から成立していること

を理解するほど十分に洗練されたにもかかわらず、我々の計算機は有限の数を取

り扱わざるを得ないことである。我々がより多くの点を加えるほど、近似エラー

は減少する。しかし、我々は計算機の速度とメモリに制限を受ける。 

2.1 物理的な公式化 

水深平均モデルは、質量と運動量の保存の基本的物理原理と、駆動力と抵抗力を

流体の性質と動きに関連付ける構成則に基づいている。抽象化プロセスをわかり

やすく説明するために、質量保存則について以下にやや詳しく述べる。より複雑

な運動量の保存則については、必要な構成則を考慮しながら簡潔に概要を説明す

る。 

2.1.1 質量保存 

図 1 に示すように、水平面では矩形（大きさΔx とΔy）で鉛直方向には水深 H の

深さを持つ仮想的なコラムを流れの中に考える。この箱もしくは「コントロール

ボリューム」における質量保存は次のことを述べている。： 

箱の中の時間に関する水の体積変化率は、箱の側面を横切って水が箱に流入する

正味の単位時間当たりの流入量と等しい。 
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Figure 1: Definition sketch for the conservation of mass  

 

箱の中の水の体積変化は、水深を変化させることによってのみ実現できるので、

体積変化速度=AΔH/Δｔで計算することができる。ここで A=ΔｘΔｙである。 

ある面に垂直な流速成分は正味流入量を知るために重要である。上の図において

は、流れの一般的な方向は左下から右上向きであるが、垂直に横切る成分だけが

示されている。水が箱の側面を通過する単位時間当たりの量は側面に垂直な速度

と側面の面積の積に等しい。水深は側面から他の側面へ向かって変化可能であり、

また流れは箱に入ったり、箱から出たりするので、正味の流入量は次のよう表さ

れる。： 

 

これより、質量保存則は、定量的に以下のように書ける。 

 

式を整理すると、 

 

また、次のようにも書ける。 
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この式について、箱の大きさと時間変化を無限に小さくすると、次のようになる。 

 

これは、質量連続の微分方程式である。単位幅あたり流量を qx =HU、qy = HV と

表せば、連続の式のもうひとつの形を与える。 

 

どちらの形式でも、連続の式は流れの中のあらゆる場所における流速の２つの成

分（または流量強度）と水深に対する関係を与える。一般に、任意の場所で式と

未知量の数が一致するために、さらに２つ以上の関係式が必要である。他の 2 つ

の関係式は、2 つの成分の運動量保存則によって与えられる。 

2.1.2 運動量の保存 

物理的には意味がまったく異なっているが、運動量保存方程式を導くための過程

は連続式のそれによく似ている。（長くて退屈になる）その誘導過程をじっくりと

考えるよりは、式中の項の物理的な意味に注目しよう。 

流れの中の仮想的なカラムもしくは箱を再び思い浮かべよう。x 方向の水の運動量

の保存は次のようになる。： 

箱の中の時間に関する x 方向運動量の変化率は、箱の側面を通過する x 方向の運

動量の正味の流入率とｘ方向の箱に働く合力の和と等しい。 

運動量の流れと力は、下記の図 2 で示される。 
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Figure 2: Definition sketch for conservation of momentum. 

 

この図において、P1 と P2 は、箱の側面に働く圧力である;Pb は、河床の傾斜によ

り生じる圧力である。M1 と M2 は、考えている方向の運動量フラックスである。

M3 と M4 は、横方向の流速成分によって運ばれる x 方向の運動量である。fb は河

床の摩擦力である。F3 と F4 は、乱流により生じる横断方向せん断力である。そし

て、F5 と F6 は、乱流により生じる法線方向の力である。風による表面摩擦と地球

の回転によるコリオリ力を考慮していない点に注意しなければならない。 

運動量保存原則は次のようになる。 

 

これらの項の全ては、解を得るためには水深と流速成分に関して評価される必要

がある。この点が、最も重大な近似が行われる部分である。 

運動量は質量と速度の積であり、質量は体積と密度ｐの積なので、運動量の変化

率は以下のようになる。 

 

流速が水深方向に一定であると仮定すれば、運動量フラックスは、次のようにな

る。 
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そして、横方向の運動量フラックスは同様に、 

 

静水圧分分布の仮定によって、圧力は水深を用いて評価することができる。 

 

S0x は x 方向の河床勾配である。 

河床と箱の側面のせん断力は、せん断応力に面積を乗じることで表される。 

 

また、乱流による法線方向の力は次のように評価することができる。 

 

これらを保存則に代入し、数学的ないくつかのステップを踏むと、x 方向の運動量

保存の式が得られる。 

 

は摩擦勾配である。 

定式化を完成させるためには、河床と側面のせん断力の関係を定めておかなけれ

ばならない。これらの応力は主に乱流の相互作用から起こるので、評価にはかな

りの不確実性が含まれる。一般的に、二次元のマニングの式が摩擦勾配のために

使われる 
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そして、Bousinessq タイプの渦粘性が、横方向せん断応力 t に対して使われる。 

 

パラメータ n とνt は、定数や流体の物性値ではなく、流れの状態に依存するもの

である。結果的には、これらのパラメータはモデルによる予測を観測データと一

致させるように変更するチューニングまたはキャリブレーション用のパラメータ

になってしまう。1 次元河床モデリングと比較すると、マニングの粗度係数 n はよ

く知られているが、渦粘性係数はあまり知られていないものである。 

y 方向においても、プロセスは同じであり、結果として生じる式も同様である。流

れの中のあらゆる場所で連続方程式と 2 つの運動量方程式を適用すると、すべて

の場所における水深と流速成分に対して解決するだけの十分な情報を得ることが

できる。残念なことに、その解を見つけることは難しく、近似解にならざるを得

ない。 

2.2 水深方向平均流れ方程式の数値モデリング 

与えられた支配方程式において、数値モデルの開発には 2 つの本質的なステップ

がある。 

1.離散化.無限個の未知量に対する無限個の式は、時空間の有限個のメッシュもし

くはグリッド点へと変換される。この段階で、微積分演算は、代数演算に変換さ

れる。 

2. 解法 第一段階で作成された代数方程式が未知の節点変数に対して解けるよう

にするために、計算スキームや手順が考案されている。これによって代数式はコ

ンピュータコードに変換することができる数字を用いた計算式にまで引き下げら

れる。 

各ステップには多くの方法がある。一般的な離散化方法としては、有限差分法、

有限体積法、有限要素法がある。解法には陽形式と陰形式があり、後者は、いろ

いろな反復法や非線形あるいは線形方程式の直接解法に依存する。 
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2.2.1 有限要素法 

有限の要素法の基礎は、重み付き残差方法として知られるより一般的な手法であ

る。その考え方は、限定されているが多くの調節可能な自由度を持つ試行関数を

用いて支配方程式を近似的に解くことができるというものである。ある意味では、

そのプロセスは観測値に対する（直線という）カーブフィッティングに類似して

いる。直線は、2 つの自由度を持つ限定された関数である。これらの 2 つのパラメ

ータ値は探索され、それは最小誤差を与える。 

水深平均の連続方程式と運動量保存式は、短縮形で、以下のように表記できる。 

--  

変数 H、U、V に対する試行関数 H＾、U＾、V＾を導入し、これらを式に代入し

ても、それらが必ずしも元の式を厳密に満足するとは限らない。かならず残差が

生じる。 

 

この段階での目的は、残差をできるだけ小さくすることである。重み付き残差法

は、残差に重み関数を乗じ、領域全体に積分し、残差をゼロするというものであ

る。試行関数におけるあらゆる自由度に対して、別々の重み関数が未知量の数と

同じ数の式を生成するために使われる。例えば、連続式は以下のように表される。 
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ここに Ni は i 番目の重みあるいは試験関数である。領域全体の積分は、空間内の

分布を単一のある値に変換するのに役立つ。 

重み付き残差法の秘訣は、異なる状況に対して機能する一般的に十分な方法にお

いて、良い試行関数や試験関数を選ぶことである。ここでは、補間法の考え方が

大変役に立つようになる。もし、解かれるべきパラメータである計算点における

水深に関して、所定の計算点数が存在するように水深Ｈの試行関数が構築された

とすれば、計算点間を内挿する関数が試行関数として用いられる。内挿関数が、

各点において「影響」あるいは「基底」関数のような形で記述される。つまり試

行関数は項の総和である。 

 

ガラーキンの重み付き残差法では同じ関数を基底関数としても試験関数としても

用いており、必要とされる関数の選択を非常に単純化している。 

有限要素方法は、重み付き残差法にさらに二組のステップを与える。最初に、対

象領域は（有限要素と呼ばれる）離散化面に分割される。離散化面は節点間の接

続によって輪郭が示される。図 3 に三角メッシュを例示する。 

Figure 3: A sample triangulation 

-- 

節点は、三角形の頂点にある。単純な内挿または基底関数はつくるのが簡単であ

る。例えば、節点間で線形に変化する、などである。特定の節点から隣接した節

点までの間だけに及ぶものであるという点で、これらの基底関数は「局所的」で

あると考えられる。その範囲の外側ではゼロである。節点 j の基底関数は、節点 j

において（単位高さの）ポールと三角形の辺で節点 j に接続された他のすべての節
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点をペグに見立てた"テント"関数として視覚化される。 

有限要素法においては、重み付き残差法における積分操作は、要素積分の総和と

して実行される。基底関数の局所的性質のため、特定の要素内の接点を持つ関数

のみを積分すればよい。たとえ他に何千ものノードがあるとしても、３つのノー

ドを持つ線形の三角要素であれば、３つの試験関数に対する３つの基底関数の合

計９個の積分を行えばよい。 

有限要素法の最大の利点は、幾何学的柔軟性である。要素は簡単にサイズと形を

変えることができ、非常に重要な箇所や変化の激しい箇所でメッシュを細かくで

きるばかりでなく、複雑な境界線を表現することができる。 

2.2.2 離散化誤差 

どんな離散化方法でも、近似によっていくらかの誤差を生む。誤差の原因とその

大きさについてのイメージを持っていることが、計算の結果を評価し、改善措置

をとるにあたって重要になる。ここで、議論をはっきりさせるために、誤差とは、

（節点だけでなくあらゆる点における）数値解と解析解の差、と定義しておく。

解析解と観測値の違いはまた別の問題とする。 

有限要素法には、計算操作に関連した 2 つの重要な誤差の原因がある。第一は、

内挿誤差である。下記の図 4 の 2 つの異なる区間分割を用いた線形回帰を見れば、

より多くの区間があることがよりよいことは明らかである。 

Figure 4: Error related to piecewise interpolation. 

 

第二の誤差は、より微妙なものである。重み付き残差方法は、実際には加重平均

プロセスである。どんな特定の点においても、節点の値はその点を囲んでいる状

況を反映する。節点近傍で条件に大きな変化があるならば、その点の値はどちら

かに偏ってしまう可能性がある。これを解釈する単純な方法は、ある点の計算結

果はその周りの要素の平均であると考えることである。 

水深平均流許計算においてこの問題に関する 2 つのよくある事例を紹介する。第

一は、傾斜護岸の近傍で発生するものである。護岸の最下部のノードは、河床（比
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較的均一な速さ）と護岸（よりゆっくり、流速が減少している）の状況を反映す

る。その平均値は、特定の点の流速より遅い傾向がある。もう一つのケースは、

河川中に孤立した砂州である。節点が砂州の最上部にあり、周囲の節点のすべて

が水深の深いところにあるならば、砂州の最上部の流速は周辺の影響を受けて非

常に速くなってしまう。その点での水深はおそらく小さいので、射流状態になる

ほどのフルード数になってしまうといった問題を引き起こす。 

こうした離散誤差は、要素をより小さくすることで解決できる。これは、同じ物

理的な面積に対してより多くの要素とより多くの節点を配置することを意味する。

コンピュータモデリングの技術とは、重要な部分には十分な精細さを与えつつ、

実用的な計算時間で実行できるようにするところにある。 

2.2.3 解法 

有限要素法や他のどの離散化手法の結果も、全ての未知の水深と流速に関する連

立非線形代数方程式である。これらの式を解くプロセスは、コンピュータ・リソ

ースを要求する。 

たいていの水深平均流況モデルは、定常状態の結果が欲しいだけであっても、非

定常状態を解くことになる。これは、任意の初期値あるいは初期条件から制御さ

れた安定した繰り返し計算法を与える便利な手法である。一般に陽解法と陰解法

と呼ばれる 2 つのアプローチが使われる。 

陽解法は、ある節点の新しい時刻の変数値を得るために、前の時刻における周囲

の節点の値に基づいて、解く。このアプローチは、独立に各値を計算するといっ

た大きな利点を持つ。行列計算の必要がないので、記憶要領は小さくで計算実行

速度は速い。デメリットは、計算の安定性を維持するためにタイムステップが制

限されるということである。Courant-Lewy- Freidrichs 条件（CFL 条件）は、許され

る最大の時間ステップの指針である。 

 

この条件は、ある節点から次の節点へ伝搬する浅水波によって得られる時間に関

係している。どんな離散面においてもメッシュ間隔が小さくされたときは、全計

算過程の時間ステップは小さくしなければならない。 

第二のアプローチは、陰解法と言われる。ここで新しい時間での全ての変数の値
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は、前のタイムステップの値だけでなく、お互いに依存することが考えられる。

未知量が相互に関連しているので、非線形および線形代数学の知識を用いた努力

が連立方程式を解くために要求される。 

一般的に、大きい行列（マトリックス）になってしまう。あるメッシュに N 個の

節点があるとすれば、各タイムステップにおいて解くべき未知量の数は3Nである。

これらの相互接続を記述する完全マトリックスは、3N ×3N となる。N が 10,000

であるならば、マトリックスは 7.2 ギガバイトのメモリ容量を必要とするであろう。

幸いにも、完全マトリックスは、通常必要でない。マトリックスの要素の大部分

は、ゼロである。記憶容量のより現実的な評価は、3N × 3B である。ここで B は

メッシュのバンド幅である。大雑把に言って、バンド幅は結合している点の節点

数間の代表的な最も多きな差である。10,000 個に節点を持つ問題では、バンド幅

がおよそ 100 オーダーである。必要なマトリックスは、100 メガバイト未満（大き

いが、処理できる）である。 

マトリックスの解法のための計算時間は、およそ NB2 に比例する。B が N の平方

根で比例するならば、マトリックス・サイズは N3/2に比例し、マトリックスの計算

時間は N2に比例する。すでに大きい問題にいくつかの節点を加えることは記憶容

量と計算時間にとって高価であると言える。さらに、計算のモデル化においては、

誤差を最小にする十分な離散化を与える問題と合理的な計算時間内で解を得るこ

とは本質的なトレードオフ問題である。 
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3.0 River2D モデル解説 

3.1 概要 

River2D モデルは二次元、水深平均流体力学モデルであり、さらに、主に自然流路

や河川で使用のために開発された魚類生息場モデルである。それは保存形の

Petrov-Galerkin upwinding 法に基づく有限要素モデルである。それは、常流と射流、

冠水域と無水域を計算できることが特徴である。厚さが変化するアイスカバー（水

表面上の氷）や不連続なアイスカバーをモデル化することもできる。それは、多

くの理論、実験、観測結果の比較を通して確認された。モデルの定式化と実施の

詳細な記述は、Ghanem ら（1995）の文献に記載されている。 

3.2 謝辞 

River2D モデルは、以下の援助を受けてアルバータ大学で開発されたものである。

カナダ自然科学・工学研究委員会、漁業・海洋部、カナダ政府、アルバータ環境

保護局、合衆国地質調査所。プログラムコードは F.Hicks, A.Ghanme, J.Sandelin, 

P.Steffler および J.Blackburn によって作成された。T. Waddle は、ガイダンスと実務

への応用のためのモデルの開発に関するフィードバックを提供した。モデルは今

も発展中であるが、それは C.Katopodis によって進められ、支援されている。著作

権は彼ら個人とアルバータ大学が所持している。 

3.3 利用条件 

River2D モデルは（Windows（95/98/2000/ME/NT/XP）の実行可能プログラムの形式

で）パブリックドメインにおいて利用できる。完全性のある正当な理由がなくま

たどんな特定の問題にでも適応性がないとき、プログラムは提供される。この注

意書きが含まれ、モデルの使用が適切に認められている限りにおいては、プログ

ラムと付随するユーティリティ、例題のデータ・ファイル、説明書は自由にコピ

ーし、配布してもよい。River2D とその付随するユーティリティ・プログラムは、

更新の余地が多く残されている。プログラムと説明書の進展は連続的に行ってい

るものの、散発的である。重要な機能が加えられるときはいつでも、更新された

プログラムは発表される。建設的なフィードバック、バグ・レポートと議論を歓

迎する。 

問合せは、pmsteffler@civil.ualberta.ca または jblackburn@civil.ualberta.ca 
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4.0 定式化 

4.1 概要 

River2D モデルは、二次元で、水深平均有限要素モデルである。それは、自然の流

れと河川の使用を目的としたもので、常流／射流の遷移、アイスカバー、露出・

冠水する河床に適合する特別な特徴を持っている。基本的に非定常モデルである

が、定常状態に加速的な収束を用意している。魚類生息場モジュールは PHABSIM

の重み付き利用可能面積アプローチに基づく。そして、三角形の不規則なネット

ワーク的幾何学表現に修正される。River2D は、全ての入力と出力のために SI 標

準単位（kg、m、s）を使う。 

非常に大きい空間領域の場合、より小さい内部の領域のより詳細な解が、流体力

学的または生息場的理由において重要かもしれない。ユーザーがコンポーネント

を個別に取り扱えるように、River2D モデルは、副サイトを取り出せる能力をユー

ザーに能力を与えるコンポーネントを持っている。このコンポーネントは、ユー

ザーに既存の粗い定義済みメッシュ内から境界を定義したり取り除いたりするこ

と可能にしている。このとき、この境界は詳細なサブメッシュをつくるために

R2D_Mesh で使われることができる。そして、それは River2D モデルを使って、そ

の後解かれる。境界抽出プロセスは、流れ関数、流線および流管の概念に基づく。 

4.2 流体力学モデル 

River2D モデルの流体力学的要素は二次元の保存形式の水深平均サンブナン方程

式に基づいている。これらの 3 つの式は、質量、運動量ベクトルの 2 成分の保存

を表す。実際に解かれる従属変数は、水深と 2 つの各座標方向の流量強度である。 

質量の保存： 

 

x-方向運動量の保存： 
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y-方向運動量の保存： 

 

ここで、H は水深、U と V はそれぞれ x と y 方向の流速の水深平均流速である。

qxと qyはそれぞれ流量強度であり、以下の式で通して流速成分と関係づけられる。 

 

と 

 

g は重力加速度、ρは水の密度、S0x と S0y x と y 方向の河床勾配である。Sfx と

Sfy は、対応する摩擦勾配である。τxx、τxy、τyx とτyy は、水平方向の乱流

による応力テンソルの成分である。 

4.2.1 基本的な仮定 

1. 垂直方向の圧力分布は、静水圧である。通常、これは急勾配や河床勾配が急

激に変化する領域において精度に制限を受ける。大雑把に言って、水深の約

10 倍未満の規模の水平方向の河床形状（例えば河床波など）は精度の良いモ

デル化は行えない。同じように、およそ 10%を超える流れ方向での勾配は、

正しくモデル化されない。 

2. 水深方向の水平流速の分布は本質的に一定である。仮定された速度分布は、

与えられた水深平均流速の解釈において使用されてもよい、しかし、分布は

内部の計算によって一定であるとみなされる。具体的には、二次流と循環に

関する情報は、利用できない。 

3. コリオリ力と風による駆動力は、無視できると仮定される。非常に大きい水

塊において（特に大きい湖や河口において）、これらの力は重要かもしれない。 

4.2.2 河床抵抗モデル 

摩擦勾配項は、水深平均流速の大きさと方向に関係すると仮定された河床せん断
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応力に依存する。x 方向で例えば、 

 

ここで、τbx は x 方向の河床せん断応力で Cs は無次元シェジー係数である。この

係数は、次式を通して境界の有効粗度高さ（ks）と水深と関連している。 

 

与えられた水深 H 対して、マニングの粗度係数 n と ks は次式で関係づけられる。 

 

ここにｍは 

 

マニングの粗度係数 n よりも広い水深の範囲において一定値でありつづけるので、

有効粗度高さは抵抗のパラメータとして選ばれた。 

相対粗度への非常に少ない深さのために（式７は以下で置き換えられる） 

 

そしてそれは、任意の水深に対して滑らかで、連続的で、非負の関係を与える。

この公式に物理的な根拠はない。 

有効粗度高さ（単位はメートル）は、入力されたファイル中のメッシュの各節点

で指定される抵抗パラメータである。主に河床材料粗度による抵抗については、

ks の初期評価は最大粒径の 1～3 倍として得ることができる。最終的な値は、水表

面高さと流速の観測値にモデル結果を適合させることによって得らるべきである。 
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4.2.3 横剪断モデル 

水深平均された横方向乱流せん断応力は、Boussinesq タイプの渦粘性でモデル化さ

れる。例えば： 

 

ここでνt が渦粘性係数である。渦粘性係数は、3 つの要素から成立される仮定さ

れる。すなわち、定数、河床せん断を表す項そして横方向せん断を表す項である。 

 

ここにε1、ε2 とε3 はユーザーが定義できる係数である。 

ε1 のデフォルト値は、0 である。式 12 の中の二番目の項が流れに対するνt を適

切に記述できないかもしれない場合に、この係数は非常に浅い流れの計算を安定

させるために用いられる。ε1 の合理的な値は、モデル化された現場の平均流れ条

件（平均水深と平均流速）を用いて、式 12 の二番目の項を評価することによって

計算することができる。 

ε2 のデフォルト値は、0.5 である。河川での横分散係数との類推によって、0.2～

1.0 の値が合理的である。大多数の河川乱流は河床せん断で発生するので、この項

は通常最も重要なものである。 

深い湖の流れまたは強い横方向の流速流出勾配をもつ流れでは、横方向のせん断

が主要な乱流発生メカニズムであろう。強い再循環領域は重要な例である。これ

らの場合では 3 番目の項（ε3）が重要になる。それは、本質的に 2D（水平）混合

距離モデルである。混合距離は、水深に比例していると仮定される。ε3 に対する

代表的な値は 0.1 である、しかしこれは伽利ぶれーションによって調節されるかも

しれない。 

4.2.4 干出・冠水領域の処理 

二次元のモデル評価の実行において、従属変数として水深は事前には分からない。

したがって水が覆っている水平面的な範囲は未知である。水深が非常に浅い場合

またはモデル化された領域の一部の上にまったく水が存在しない場合では、重要
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な計算の困難に遭遇する。River2D モデルは、これらの領域で表面流方程式を地下

水流方程式に変更することによってこれらの発生を処理する。正（地上）と負（地

下）の水深に関する連続的な自由表面が計算される。この手法では、境界条件の

変更や更新を行うことなく計算を続けることができる。さらに、モデル化された

領域選択と境界条件制限は、非常に単純化される。具体的には、水の質量保存式

は、次式に置き換えられる。： 

 

ここで、T は透過率であり、S は人工の帯水層の貯留係数である。そして、zb は地

下水面高である。 

地下水流れの透過率と貯留係数は、ユーザーによってセットされる。透過率は、

実際の地下水流量が無視できるような低い値にセットされるべきである。デフォ

ルトは、0.1 である。与えられた領域に対して、貯留係数は地面が地下水面の単位

低下あたりに放出する水量の尺度である。デフォルトの storativity は、1 にセット

される。精度の良い非定常解析について、あるいは地下水応答率の向上にとって、

貯留係数は小さくしなければならない。 

4.3 単純な氷カバー・モデル 

River2D は、既知の形状で浮かんでいるアイスカバー（つまり、氷の厚さと粗度が

分かっているアイスカバー）の下の流れをモデル化する能力がある。アイスカバ

ーが河川表面に存在するとき、それは多くの方法で流れの水理に影響を及ぼす。 

1. アイスカバーは、せん断応力が働く面積を増やす（連続的なアイスカバーが

ある時は係数 2 まで） 

2. アイスカバーの底面粗度は、流れに対するせん断応力の大きさが増えること

よって全水路抵抗体を増やす。 

3. 1 と 2 は平均流速の縮小に帰着する。そして、それによって流量を合わせるた

めに水深が大きくなる。 

4. アイスカバーの水面下の厚さと新しい水深の和に等しい値にまで水表面高さ

が増加される。 

アイスカバーが River2D に入力されるとき、モデルはこれらの氷の効果を説明する

ために水表面方程式を変更する。連続式は変わらないが、運動量方程式は次式に
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置き換えられる。 

x-方向運動量の保存： 

 

y-方向運動量の保存： 

 

ここで、今や H は自由水面の水深を表すが、一方 D は河床からアイスカバーの底

までの厚さを表わす。 

これら二つには、以下の関係がある。 

 

ここで、ts はアイスカバーの水面下の部分である。水面下の厚さは、全氷厚さ（t）

に関連があり、次式を用いる。 

 

ρi とρは、それぞれ氷と水の密度である。依然として U と V はそれぞれ x と y

座標方向の水深平均速度であるが、いまやそれらは次式を通して流量強度 qx、qy

に関係している。 
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これらの式中の項は、すでに説明した通りである。 

実際、これは計算のコードにおいて存在する運動量方程式の形式であるが、氷が

存在しないときには、これらの式は単に開水路の運動量方程式になる。これらの

式は、1 つの付加的な仮定を含む‘ice-free’形式と同じ固有の仮定を持つ。すなわ

ち、アイスカバーは、空間に固定される。したがって、氷上の水によって適用さ

れるどんなせん断力にも、この氷は反応しない。 

4.3.1 氷と河床抵抗が共存する場合のモデル化 

氷が存在する時、摩擦勾配項は河床せん断応力に加えて氷せん断応力に依存する。

例えば x 方向では、 

 

ここで、τbx とτix がそれぞれ x 方向の河床と氷のせん断応力である。もし平均

応力を次のように定義すると 

 

 

Chezy 係数（Cs）は、次式を通して、アイスカバー（D）下の水深に関連がある。 

 

ここで kc は河床と氷の合成有効粗度高さであり、Sabaneev 式（アシュトン（1986））

を用いて評価される。実用のために粗度高さに関して修正された時、Sabaneev 式



 

 23 

は次のようになる。 

 

ユーザーには Sabaneev の式の使用に関する仮定と限界を十分に理解するためにア

シュトン（1986）の論文を読むことを勧める。 

氷でおおわれた領域をモデル化するとき、一部のユーザーは氷のない状態に対す

るモデルを調整することにより最初に河床粗度を決定することを選択するかもし

れない。氷条件下でのモデルの較正は、氷の粗度値だけを調節することによって

達成できる。しかし、水深や流量が同じであったとしても、氷のない条件で校正

された河床粗度高さは氷で覆われたケースに対して適用できない場合があること

に注意すること。結局、このアプローチによるモデル校正を達成するために必要

な氷粗度高さの値は、物理的に合理的でないであろう。このようなことで、河床

と氷の粗度高さの 1 つ以上の組み合わせが同じ合成粗度をもたらすことを理解す

るのは大切である。またユーザーは水理計算において実際に考えられる唯一の合

成粗度であることを覚えておくべきである。 

4.4 魚類生息場モデル 

River2D の魚類生息場コンポーネントは、重み付き利用可能面積（WUA）（Bovee

（1982））に基づく。概念は魚類生息場モデルの PHABSIM 系統において用いられ

ている。領域のあらゆる点で評価される合成最適指標（CSI（範囲 0.0-1.0））とそ

の点に関する"tributary area"の積の集計として WUA は計算される。River2D では、

点は有限要素メッシュの計算節点である。また tributary areas は全ての他の節点よ

りある特定の節点に近い面を含む「ティーセンポリゴン」である。 

水深、流速および水路指標に対する個々の最適指標の組み合わせとして各節点で

の CSI は計算される。CSI の三重積、調和平均、または最小値、計算のオプション

は利用可能である。各パラメータの最適指標は、別に供給される適切な魚類の選

好曲線から、線形内挿によって評価される。流速と水深は、モデルの流体力学的

コンポーネントからもとめる。水路指標の値は、異なる魚種と成長段階に対して

水路サブストレートまたはカバーに依存する。これらの値は、別々の水路指標フ

ァイルから計算節点へ書き込まれる。補間法は線形である（連続する）か最も近

い漸近（離散的な）である。 
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4.5 境界抽出モジュール 

境界抽出コンポーネントは、流線と流管の概念に基づく。流線は、流れ場の中の

仮想的な線（その線上の任意の点において流速ベクトルがその線に接している）

として定義される。したがって、理論上では、流線を横切る流れはない。定常流

では、流れ場の中の任意点において速度ベクトルの方向は変化しないので、流線

は空間に固定される。2 次元流では、流線の式は 

 

スカラー関数を次のように定義する。 

 

このスカラー関数ψ(x、y)は流れ関数と呼ばれる。ψの全微分を考える。 

 

式 26 を代入すると、上式は以下のようになる。 

 

流線（式 25）の式は dψ= 0 における式 28 の特別お場合であることを示している。

これは、ψがどんな流線に沿っても一定であることを示している。 

図 5(a)において、二次元流れ場で少しだけ離れている 2 本の流線、ψ1 とψ2 があ

る。どちらの流線も横切る流れは存在できないので、流線は流管と呼ばれるもの

に流れを閉じ込める。今、無限に近い 2 本の流線ψとψ+ dψ（図 5(a)においても

示されている）を考える。図 5(b)から、次のように、この流管要素（ds を渡った）

内の流れまたは流量を計算することができる。 

 

これより、 
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その結果、基本的な流管を横切ったψの変化は、流管を通過した流量に数値的に

等しい。今、上式がψ1 とψ2 の間で積分されたとすれば、任意の 2 本の流線間の

流れ関数の差がその流線間の流量に等しいことがわかる： 

 

図 5(a)において、流れは左から右に流れる。このときψ2 >ψ1。ψ2 <ψ1 ならば、

流れは右から左に流れる。 

この流れ関数と流量の関係によって、水路の一方の側で任意にψ1 =0 とすると（水

路の側は流入・流出境界ではないと仮定する。このとき定義によってそれは流線

となる）、水路の一方の側のψ2 の値は、水路を横切った全流量と等しい。この場

合、流れの中の任意点における流れ関数の値（ψp）は、流線ψ1 とψp によって

定義される流管の流量と等しい。ψp がψ2 の値に近づくにつれ、流管の流量は水

路の全流量に近づく。この理由で、水路を横切った流れ関数の値は、累積流量と

呼ばれている。 
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Figure 5: The relationship between stream function and discharge:（a） a schematic of a 

stream tube and (b) the calculation of discharge across an elemental stream tube. 

-- 

（副サイトを含む）広いサイトから分かれて個別に扱われるべき副サイトの計算

メッシュを解くために、この副サイトを定義している境界に沿った境界条件は既

知でなければらない。境界が水路を横切っている場合、境界条件は水路の側で流

れなし条件（流入・流出がない）であることが知られている。しかし、全境界が

流れの領域内にあるならば、もはや問題はささいなことではない。定義により流

線は流入・流出のない境界であるので、流れの領域内の計算境界を定義するとき、

追いかけていく論理的な道筋が存在する。このために、大きなサイト内からの新

しい狭いメッシュの計算境界が定義されるとき、River2D での境界抽出モジュール

は流線と流管の概念を使う。 

流線を精密に得るために、流れ関数の値は、計算領域の中であらゆる節点で既知

でなければならない。計算領域内の流入・流出のない境界のひとつが流線である

と仮定しながら流れ関数が計算されるなら（ここでψ0）、流れ関数は水路内の累

積流量を示すであろう。River2D の境界抽出プロセスにとって流線の位置のみが必

須である。しかし、流れ関数の値が水路の累積流量を表すとき、流れ機能の概念
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は物理的な意味をもつ。River2D モデルにおいて、累積放出の計算は、２ステップ

で実行される。最初のステップは、近似解の計算を含んでいる。第 2 ステップで

は、近似解を有限要素法を用いて近似解を修正する。 

近似解において、領域内のすべての節点におけるψの値を得るために流線の式 28

は次の離散式の形で用いられる。 

 

式 32 は、Δx とΔy によって定義される距離だけ離れた 2 点間のψの相対的な差

を与えるだけである。したがってψの値が水路を横切る累積流量を表すために、

水路の片方に沿った流線はψ= 0 の値が与えられる。River2D モデルにおいて、未

知の節点ψを計算するために既知の節点ψを用いて、領域を横切って掃きだし

（sweep）や進行（march）を行うために式 32 は使用される。掃きだしのための既

知の開始節点ψは一つの流入・流出がない境界に沿うすべての節点におてψ=０と

することで得られる。このとき、領域内のすべての節点がψの値を持つまで、計

算メッシュを横切って計算は進行する。 

全計算領域の渦度流れ関数方程式を解くことによって洗練された解が得られる。 

2D 流れでは、渦度ベクトル（η）は z-成分だけである。： 

 

式 26 を式 33 に代入すれば渦度流れ関数方程式が得られる。： 

 

Galerkin 定式化に基づく有限要素法を使うことによって領域内のすべての接点に

対して、この式が解かれる。領域内のすべての節点におけるψを同時に解くので、

この方法は掃きだし法よりもより洗練された解を与える。有限要素法用いて問題

を解決するためには、その問題のための境界条件が既知でなければならない。式

34 に対して、2 つの可能な境界条件がある。流入・流出のない境界はψの一定を

持つ。一方、流入・流出のある境界は次式のようになる。 



 

 28 

 

これは、流線は流れ境界に垂直でなければならないという意味である。二番目の

境界条件は、Galerkin 定式化で取り扱われる。しかし、一番目の境界条件は、解を

得るためには既知であることが必要がある。単純な水路の場合、1 つの流入境界と

1 つの流出境界で、流入・流出のない境界に沿ったψの値が、水路の中の全流量（Q）

に基づいて決められる。したがって、一つの流入・流出のない境界に沿って境界

条件はψ= 0 となる。またもう一つの流入・流出のない境界に沿ってψ= Q になる。

流入・流出のない境界で囲まれている中洲が水路中にあるとすれば、これらの境

界の境界条件もまた決める必要がある。残念なことに、これらの境界のψの値を

得ることは容易ではない。ここで近似解法が有利である。掃きだし法は、全ての

節点（節点が境界に沿っているかどうかには関係なく）のψ値を計算する。した

がって、内部の流入・流出のない境界に沿った任意の節点に対する境界条件は、

近似解法から得られるψの値の平均に基づいて決められる。 

4.6 流体力学のモデル実装 

4.6.1 有限要素法 

River2D の流体力学モデルで使われる有限要素法は、 Streamline Upwind 

Petrov-Galerkin 重み付き残差法に基づく。このテクニックにおいて、射流、常流、

遷移流を含む広範囲の流速条件下で安定に計算が行うことを保証するために、上

流側に偏った試験関数が用いられる。結果として、（不等オーダー）混合補間法ま

たは大きな人工拡散係数が必要とされない。 

モデル化された領域に渡って流体質量が失われたり増加したりすることなく、完

全な保存形の離散化が実行される。このことはまた、自然の流れとしての境界条

件または強制条件の実施を許す。例えば、等価な静水圧として固定された水位が

与えられ、また既知の流入流が直接知られている。 

サポートされているモデル離散化は、三角形および四角形要素上のすべての変数

の線形、2 次、3 次の内挿多項式を含む。しかし、メッシュ・ジェネレーターは、

線形三角形だけをサポートする。これらの要素は、二次元でもっとも簡単な可能

性であり、与えられた節点数に対して最小実行時間で終わる。 

このモデルは実際には非定常モデルであるけれども、遷移的な状態の解析を行っ

たり、定常解を得たりするために用いることができる。定常状態の結果に対して、

加速収束手法は系統的に時間増分を増やすことによって、最終的な完了への過程
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を速くする。 

4.6.2 Newton Raphson 法 

4.6.2 Newton Raphson 法 

流体力学方程式を解くために有限要素法を用いることは、陽的または陰的な手法

で解かれる非対称、非線形連立方程式を結果として生じさせる。River2D では、連

立方程式の解を要求する陰的なアプローチが採用される。連立方程式は非線形で

あるので、ニュートン-ラプソンの反復法が使用される。この方法では、前の時間

ステップの既知の値（Φn）を新しい時間ステップの第一近似値（Φn+1）として

用いることで、収束解が得らる。近似値が正しくない限り、下に表すような残差

が生じる。 

 

n と m はそれぞれ時間ステップと繰り返し回数を示す。反復過程の次の近似値を

得るために用いられる補正値（ΔΦ）は、以下の連立方程式を解いて決定される。 

 

ここで、[ Jn+1,m ]はヤコビ行列と呼ばれており、次式のように定義される： 

 

各々m 回繰り返された後、変数の値は次式を用いて更新される。 

 

ヤコビ行列は、式 38 を用いて解析的にまたは次の近似式を用いて数値的に評価さ

れる。 

 

ここで、δは小さな摂動である。指標 i と j はそれぞれ、式と変数の番号を表す。

River2D には、ヤコビ行列を解析的にまたは数値的に評価するオプションがある。
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解析的ヤコビ行列は数値的なものよりも速いが、数学的な微分の仮定ために、数

値的ヤコビ行列よりも精度が劣るかもしれない。特に、解析的ヤコビ行列は風上

行列の変化もしくは変化する水際位置の影響を考慮しない。 

定常状態解析を実行するとき、解析的ヤコビ行列を用いて計算を開始することが

最適である。解が収束の閾値に到達することができないならば、シミュレーショ

ンの残りの時間は数値ヤコビ行列に切り替えることが賢明である。 

水際や風上行列は時間間隔の間では固定されているので、解析的ヤコビ行列は遷

移的な現象のシミュレーションに対しても適切でなければならない。 

4.7 モデル方程式解法 

各ニュートン-ラプソン反復計算中に、式 37 で記述される連立線形方程式を解くこ

とが要求される。River2D では、線形方程式の解法の 2 つの選択肢がある。直接解

法と反復解法である。 

4.7.1 直接解法 

最初の方法は（活性領域方程式解法（Stasa 1985）と呼ばれる）非対称連立線形方

程式の直接解法を採用する。すなわち、ガウスの消去法に基づく解法である。活

性領域方程式解法において、線形連立方程式 

[A]{x} = {b} (40) 

の係数行列[ A ]は下三角形行列[ L ]と上三角行列[ U ] 

[ A ] = [ L ] [ U ] (41) 

に分解される。ゆえに、式 41 と 40 より 

[L][U]{x} = {b}  (42) 

と記述することができる。要するに、これは以下の二つの連立方程式である。： 

[L]{c} = {b}  (43) 

[U]{x} = {c}  (44)  

このとき、｛c｝を計算するために、式 43 の前方からの代入により、そしてベクト

ル｛x｝の解を得るために式 44 の後方からの代入によって、式 40 で定義される連

立方程式は解かれる。River2D では、係数行列は 3N×3N の要素の非常に大きなヤ

コビ行列である。ここで、N は計算節点の数である。ヤコビ行列は通常疎（入力情

報の多くは 0）で帯行列(大部分の非ゼロ入力情報は、優対角沿って集まっている)
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である。活性領域方程式解法は、スカイライン保管法（Stasa 1985）を用いて必要

とされるメモリ容量を減らすことのできる性質の有利性を持つ。これは必要とさ

れるメモリ容量を 3 N×3 B へと大幅に削減する。ここで、B は行列のバンド幅で

ある。しかし、バンド幅が狭くないとしたら、必要とされるメモリ容量は非常に

重要である。マトリックスのバンド幅は、形状とメッシュの節点の番号付けの関

数である。幅が狭い水路は小さいバンド幅が生じる。一方、広い水路は大きいバ

ンド幅が生じる。残念ながら、活性領域方程式解法の速度は、ヤコビ行列の必要

とされるメモリ容量の関数である。結果として、解くことができる問題の規模の

限界は利用できる RAM の関数である。 

4.7.2 反復解法 

二番目の方法は、一般化最小残差法または GMRES 法（Saad と Schultz1986）と呼

ばれている非対称線形連立方程式を解くための反復的な手法を使用する。直接解

法で必要とされる大容量のメモリが不要なので、この解法は River2D に取り込まれ

た。したがって、このことは、解くべきメッシュは直接法で解くことのできるメ

ッシュよりも大規模であることを考慮している。 

GMRES 法では、式 40 のベクトル｛x0｝の計算の初期推定値が選ばれる。結果は

次のようになる。 

{r0} = [A]{x0}-{b} (45)  

ここで、｛r0｝は残差ベクトルと呼ばれる。 

残差の構成は、なぜこの方法（全ての反復法）がほとんど容量を要求しないかに

ついて説明する。係数行列[ A ]を格納する必要がない。直接法では陽に必要であっ

た。それは、積ベクトル[ A ]｛x｝に暗に保存されていれば良い。River2D では、こ

の積ベクトルは、要素レベルで matrixvector 積を合計することによって得られる。 

このとき、残差ベクトルは、直交基底（ベクトルの直交集合）を作るために使わ

れる。： 

 

（46）はいわゆるクリロフ部分空間 Kk.と呼ばれる。それゆえに、Vk は一組のク

リロフベクトルと呼ばれている。非対称線形システムの GMRES 解法は（式 40 記

述されている）これらクリロフベクトルの線形結合を使って形成される。それは、

以下の通りである 
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ｙ１は一次結合係数である。ベクトルとそれらの係数がどのように求められるかと

いう詳細は、サードとシュルツ(1986)による GMRES 法の原文を参照のこと。それ

ぞれ新しいクリロフベクトル（そして、その係数）が計算されたあと｛x｝を使っ

て残差を評価することによって、GMRES 法の反復的な性質が明らかになる。残差

が許容できる最小誤差になるなら、解は収束したと言え、そして、どんなベクト

ルも必要ではない。要求されるベクトルもしくは繰り返しの数（k）は、許容誤差

がどれくらい厳しいかに依存する。しかし、繰り返しの数は、未知量の数Ｎの数

を上回ることはできない。これは、クリロフ部分空間が N ベクトルによって定義

されているという事実による。残念なことに、このアルゴリズムの実行時間は、

あらゆる付加的な繰り返しによて幾何学的に増加する。これは、ベクトル vi の計

算が v1 から vi-1 までのベクトルに包括的に基づくからである。この問題点を回避

するために、新しい残差ベクトル｛rm｝と新しいクリロフベクトルのセット（Vm.）

を求めるために、m ステップの解ベクトル｛xm｝を用いて、m ステップの後に m

ベクトルを求めた後に、アルゴリズムをリスタートすることができる。アルゴリ

ズムはリスタートされる。収束の望ましいレベルに達するために要求される回数

くらい多くの時間再開されます。GMRES（m）で記される GMRES のリスタート

版は River2D で使用される反復法である。 

River2D では、残差が目標許容誤差の範囲内での最小になるかリスタートまたは繰

り返しが最大数に達するまでリスタートが続けられるように、GMRES（m）が実

行される。今のところ、目標許容誤差は、繰り返しの終了ごとにベクトル{b｝で除

された残差と比較される。それは、以下の通りである 

 

リスタートまでのステップの数、m と繰り返しの最大数（k）は、また、ユーザー

が定義可能なパラメータである。これらのパラメータのデフォルト値はリスター

トが 10、繰り返しが 10 である。デフォルトの目標許容誤差は、0.01 である。これ

らの値は、わずかながらのテストに基づいて選定された。これらのパラメータの

最適値は、具体的な問題である。一般に、m の値が大きくなるにつれ、収束に要

求される繰り返し回数は少なくなる。その逆も同様である。１回の繰り返しに対



 

 33 

する所用時間はリスタートする前ではあらゆる付加的なステップによって指数的

に増加するけれども、あらゆる付加的な繰り返しは全体の計算時間において線形

的な増加を引き起こすだけである。 
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5.0 使用法 

5.1 インストール、 

River2D 実行コードは、ファイル River2D.EXE に含まれている。このファイルは、

大きさおよそ 650 キロバイトで、簡単にどんなディレクトリへでもコピーできる。 

5.1.1 モデルの必要条件 

River2D モデルは Windows 95/98/NT/2000/Me/XP で動作する。一般に、速い浮動小

数点演算性能と大きなメモリ（少なくとも 256MB、できれば 512MB）が必要です。

典型的には、およそ 10,000 ノード 20,000 要素のモデルの実行には 100MB のメモ

リが必要となり、Pentium III クラスのコンピュータなら 1 時間未満で実行する。 

5.2 入力ファイルの準備 

5.2.1 メッシュデータ－.cdg ファイル 

別のアプリケーション R2D_Mesh は、River2D モデル用の入力メッシュ・ファイル

である.cdg ファイルを生成する。これは、インタラクティブで視覚的な Windows

ベースの（95/98/2000/ME/NT）メッシュ生成プログラムである。このプログラムは、

測点と特徴線のデジタル化された位置、高さおよび河床粗度情報を含む河床地形

ファイル（.bed ファイル）をまず最初に読み込むことにより作動する。もう一つの

ユーティリティ・プログラムである R2D_Bed は、現地データから.bed を作成する

ために利用可能である。 

R2D_Mesh を用いれば、有限要素メッシュ境界とレイアウトを、地形図上に重ねあ

わせて視覚的に作成することができる。R2D_Mesh にはいろいろなメッシュ・デザ

イン・ツールが組み込まれており、メッシュの信頼性を確認しつつメッシュ改良

作業を行うことができる。満足のいくメッシュができあがれば、.cdg 入力ファイル

を生成できる。このファイル(.cdg ファイル)は、River2D モデルのデフォルトの実

行時パラメータを含んでいる。 

.cdg ファイルは、再度 R2D_Mesh で読み込むことで、更に編集を加えることがで

きる。しかし、この操作によって、River2D で計算され、.cdg ファイル中に保存さ

れた流体力学の情報は消失してしまうので注意が必要である。R2D_Mesh のための

詳細な指示は、別々のユーザー・マニュアルに含まれている。 

5.2.2 氷地形－.ice ファイル 

.ice ファイルはノードの氷属性を評価するために単純な氷カバー・モジュールが利

用する。これらの属性には、氷厚と氷粗度高さを含む。河床高と河床粗度高さが
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それぞれ氷厚と氷粗度高さに置き換えられること以外は、.ice ファイルの構造

は.bed ファイルと同一である。現地データから氷ファイルを作成するには、R2D_Ice

ユーティリティを利用することができる。 

5.2.3 河道指標－.chi ファイル 

河道指標ファイル（.chi ファイル）は計算ノードにおける河道指標の適性指数を計

算するために生息場モジュールで用いられる。.chi ファイルの構造は、各点の水路

粗度パラメータが河床指標値と置き換えられるという以外は.bed ファイルと同一

である。R2D_Bed ユーティリティを使って現地データから河道指標ファイルを生

成することができる。.bed ファイルと同様に、.chi ファイルの中の点と.cdg におけ

る計算ノードは通常異なる場所にあるため、生息場解析にあたってはデータの内

挿が行われる。 

なお、河道指標ファイルは River2D の流体力学解析のためには必要ではない。 

5.2.4 魚の選好性－ .prf ファイル 

生息場解析にあたっては、個々の魚種／成長段階ごとに個別の魚の選好性ファイ

ル（.prf ファイル）が必要である。各.prf ファイルは、特定の種／成長段階に対す

る流速、水深、河道指標の選好曲線を表すテーブルを含んでいる。テーブルは、

点の間の値を内挿して求めるタイプと、点の値だけしか出力しない直接ルックア

ップ・テーブルの２形式を指定することができる。 

5.3 River2D を実行する 

River2D は、そのアイコンをダブルクリックすることで標準の Windows プログラム

として実行される。メインの River2D ウインドウを開くと、初期状態は空白のウイ

ンドウが開き、使用上の注意と短い紹介を含んだ About River2D ウインドウが現れ

る。About River2D ウインドウを閉じた後のウインドウの様子を図 6 に示す。 
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Figure 6: The elements of the River_2D screen. 

 

通常の作業手順は、まず有限要素メッシュと初期流況が定義された.cdg ファイルを

入力することである。続いて、解析プロセスを視覚化するために表示オプション

を設定する。必要であれば、境界条件の値を変更する。以上で、流体力学計算の

準備が整ったことになる。さらに、計算結果が適切かどうかを確認するために結

果の視覚化機能を使用する。それで OK であれば、続いて生息場分析を実行する。

最後に、結果をいろいろな形式でファイルに出力することができる。デフォルト

の出力フォーマットは、.cdg ファイルである。この.cdg ファイルを使って、さらに

境界条件を変更した計算などに利用することができる。入力.cdg と出力.cdg ファイ

ルの違いは、時間と流れ変数（水深と流速）が最新の計算結果に更新されている

という点だけである。 

流体力学計算の結果が満足のいくものでないならば、解を改善するために利用で

きるオプションがある。メッシュへをわずかに調整すれば良いだけであるならば、

River2D に組み込みのメッシュ編集機能によってメッシュを細分化したり、河床高

や河床粗度を修正したりすることができる。完全に新しいメッシュを作ることが

必要な状況なら、新しい.cdg ファイルをメッシュ・エディタ（R2D_Mesh）を使用

して作成したほうが良い。いずれの手段をとるにしても、修正したメッシュを用

いて再度流況計算を行う。許容できる解が得られるまで、この編集プロセスを繰

り返すことになる。 

River2D を利用するにあたって、上で概説される典型的なプロセスの中には、以下

の６つの操作グループがある。 
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1. 標準の Windows 操作： これらは、標準の Windows と同様、File、Edit、View

と Help メニューに集められている。 

2. ディスプレイ操作： これらの操作は、情報のスクリーン表示のオン・オフ

と、その表示方法を変更する。表計算などで解析を進めるために、表示され

ている変数をコンマで分割されたデータ・ファイル（*.csv）として出力する

機能もある。これらの操作は、Display メニューに集められている。そのいく

つかは、ツールバーにショートカットが置かれている。 

3. 流体力学モデル操作： これらの操作は Flow メニューで利用できる。累積流

量を計算するためのコマンドも Flow メニューに集められている。 

4. メッシュ編集操作： これらの操作は、メッシュを改善するためのものであ

り、MeshEdit メニューに含まれている。これらの操作の一部は、ツールバー

からもアクセス可能である。 

5. 生息場モデル操作： 以下の操作は、habitat メニューで利用できる。WUA 計

算は、ツールバーからもアクセス可能である。 

6. オプション設定操作： これらの操作は、River2D でいろいろなオプションを

設定するためのものであり、Options メニューに含まれている。 

利用できる操作の詳細な説明は、以下の節において提示される。 

5.4 標準の Windows 操作 

5.4.2 File -> New 

この機能は現在実装されていない。 

5.4.2 File -> Open 

.cdg ファイルを表示するよう設定された標準の Windows ファイル・オープンダイ

アログが開く。適切なファイルを選び、ＯＫボタンを押すと.cdg ファイルが読み込

まれる。ファイルオープン以前に開いていた.cdg ファイルの情報はプログラムから

削除される（ファイル自体は影響されない）。 

.cdg ファイルで計算ができる状態になるまでには大量の情報処理が必要である。ノ

ード数とブレークラインのセグメント数にもよるが、数分かかる場合もある。処

理が終わると、River2D ウインドウに地形範囲のアウトラインが表示される。 
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5.4.3 File -> Save 

現在のメッシュ情報が元の.cdg ファイルへ保存される。通常、最新の計算水深と流

速が保存される。境界条件、粗度と河床高などの変化も保存される。生息場情報

は保存されない。保存した.cdg ファイルを開けば、分析を続けることができる。 

5.4.4 File -> Save As  

Save As コマンドは、標準の Windows ファイルダイアログを使用して、新しい.cdg

ファイルに現在の状態を出力する。元のファイルは変更されない。そして、以降

の Save コマンドは新しい.cdg ファイルを使用する。 

5.4.5 File -> Print 

Print コマンドは選択されたプリンタに River2D 主ウインドウに表示されているも

のを出力する。全ての現在の表示オプションを使って印刷する。現在のウィンド

ウディスプレーの部分の全体が１ページで印刷できるようにスケールが調整され

る。地形の形と紙の向きがマッチしていないと、出力が小さくなったり、画面上

では見えていない部分まで印刷されたりすることもある。最高の印刷結果を得る

ためには、試行錯誤でウインドウの形を調整することが必要かもしれない。ウイ

ンドウの形の調整の効果は Print Preview で確認できる。通常、縦か横の紙の形にあ

わせてウインドウの形をあわせるのがよい。 

プリンタへの出力は、Windows drawing コマンドを用いているので、どのような解

像度のプリンタにも印刷することができる。特に、非常に高い解像度のフルカラ

ー図面の印刷には時間がかかるかもしれない。 

5.4.6 File -> Print Preview 

Print Preview は現在の表示とプリンタ設定を反映したプリンタ出力のイメージを

表示する。 

5.4.7 File -> Print Setup  

Print Setup は、プリンタオプションを設定する標準の Windows のダイアログであ

る。 

5.4.8 File -> recent documents  

最近使用した 4 つの.cdg ファイルがリストされる。それらのうちの 1 つを選ぶこと

で、File->Open で選択したのと同じようにそれを開くことができる。 
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5.4.9 File -> Exit  

プログラム実行を停止し、ウインドウを閉じる右上の「X」ボタンをクリックする

ことは、同じ効果を持つ。 

5.4.10 Edit  

標準 Windows オペレーションのカット、コピー、ペーストは River2D の現在のバ

ージョンではサポートされていない。 

5.4.11 View 

View メニューの二つのアイテムは、ツールバーとスタートバーの表示を切り替え

る。ツールバーはよく使ういくつかの操作を提供する。そして、スタートバーは

現在のマウス位置の詳細情報を提供する。しかし、どちらも必要不可欠というわ

けではない。それらの表示をオフにすれば、より大きい表示域が利用できる。 

5.4.12 HELP 

現在ヘルプメニュー中で利用できる唯一のヘルプ機能は、River2D ダイアログボッ

クスについて表示するコマンドである。スタート時に最初に表示されるものと同

じである。 

5.5 追加のファイル操作 

5.5.1 File-> Save As EMF…  

このコマンドはユーザーが Windows 拡張メタファイルに現在の画面表示を保存す

ることを可能にしている。このファイル形式は、ベクトルデータとして画面を表

示するため、プレゼンテーション目的に最適である。現在、このコマンドによっ

て生成される拡張メタファイルはどのマイクロソフトオフィスアプリケーション

にでも取り込むことができる。 

5.5.2 File -> Compress Video… 

このコマンドは、非定常解析の出力として得られた AVI video ファイルを圧縮する

ものである。このコマンドを選ぶと、一連のダイアログボックスが開く。最初の

ダイアログボックスでは、圧縮するビデオ・ファイルを選ぶことを要求する、そ

して、第二は圧縮ファイルを新しい名前で保存する標準の save as ダイアログボッ

クスが現れる。圧縮ファイルは、圧縮されていないファイルに上書きすることは

できない。これを実行しようとすると、圧縮プロセスはファイルを圧縮すること

なく修了する。コマンドを選ぶと、図 7 で示すように、Video Compression ダイア
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ログボックスが開く。 

Figure 7:The Video Compression Dialog Box. 

-- 

圧縮アルゴリズム（Compressor）、圧縮品質、データ信号速度とキーフレームの出

現頻度の選択を考慮に入れる。それに加えて、圧縮プログラムの情報を提供する

About…ボタンがある。Preview ボタンで結果のプレビュを見ることも可能である。 

各圧縮方法（コーデック）には利点と欠点があるので、圧縮方法を選ぶ際に考慮

しなければならない。例えば、マイクロソフト RLE は、アニメーションのために

デザインされた。たとえそれが現実のイメージについて比較的性能が劣っていて

も、8 ビットのグラフィックイメージ（256 色）ではよく動く。対照的に、Cinepak

のようなコーデックは、動きのあるものには優秀であるが、動きの少ないものに

は適切でない。他の選択肢としては、動きの少ないものに適した Indeo と、Video for 

Windows 標準コーデックである Video 1 が含まれている。 

River2Dによって生産されるビデオ出力はもっぱらグラフィック 8ビットイメージ

による動きの少ないものなので、マイクロソフト RLE が最も適当なコーデックで

あり、Indeo と Video 1 がそれに次ぐものとなる。Cinepak やその他の動きの激しい

ものに適したコーデックは River2D ビデオには適していない。ビデオ圧縮ダイアロ

グでのコーデックのリストは機種に依存しているということに注意しなくてはな

らない。したがって、上述のコーデックの全てが選択できるとは限らない。ある

いは、上に述べられていないコーデックが含まれているかもしれない。 

5.6 ディスプレイ操作 

River2D プログラムは、モデル化されている範囲の地図を示す単一のディスプレ

イ・ウインドウを表示する。このウインドウは、アクティブで、最前面に表示さ
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れる。最下行のステータス・バーは現在のマウス・ポインタ位置の情報で連続的

に更新される。ステータス・バーにはマウスの x、y 座標ともうひとつのパラメー

タが表示される。もうひとつのパラメータとは、等高線／塗りつぶしの表示に指

定された項目の値である。特に何も指定していなければ、河床高が表示される。 

Display Menu に含まれる Display コマンドは、モデルの情報がどのようにウインド

ウに表示されるかを制御する。 

River_2D Display メニューを図 8 に示す。 

Display セッティングは印刷するためにも使われる。 

Figure 8：The River2D Display Menu 

 

5.6.1 Display -> Redraw 

Redraw コマンドは単に、まだ表示されていない変更を更新して、ディスプレイ・

ウインドウのすべての表示を描き直す。Toolbar ボタン は、この機能のショート

カットである。 
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5.6.2 Display -> Scale to Fit 

Scale to Fit コマンドは、全てのモデル化された範囲が小さい余白でウインドウに表

示されるようスケールと位置を変更する。Toolbar ボタン は、この機能のショ

ートカットである。 

5.6.3 Display -> Zoom In On Rectangle 

The Zoom In On Rectangle コマンドは、マウスのドラックによって画面上で指定し

た長方形の範囲がウインドウ全体に表示されるように拡大と中心の移動を行う。

ディスプレイ・ウインドウと選択した長方形の縦横比が異なる場合、指定以上の

範囲が表示されるかもしれない。2 つの長方形の Toolbar ボタン は、この機能

のショートカットである。この命令は、F2 ファンクションキーにも割り当てられ

ている。 

5.6.4 Display -> Zoom In On Point 

Zoom In On Point コマンドは、ディスプレイ上でクリックした任意の点を中心に、

スケールを２倍に拡大する。Zoom を繰り返すことで、次々に倍率が大きくなる。

大きい三角形の Toolbar ボタン は、この機能のショートカットである。 

5.6.5 Display -> Zoom Out 

Zoom Out コマンドはディスプレイの中心を動かさずにスケールを１／２にする。

繰り返し Zoom Out を実行することで、次々に倍率が小さくなる。小さい三角形の

Toolbar ボタン は、この機能のショートカットである。 

5.6.6 Display -> Move Center to Point 

Move Center to Point コマンドは、画面上でクリックした点がウインドウの中心にな

るように、スケールは変更せずに移動する。このコマンドは拡大率が大きなとき

に表示を水平移動させて細部を確認するのに便利である。長方形の中に点がある

Toolbar ボタン は、この機能のショートカットである。 

水平移動は、キーボードを用いても行うことができる。カーソルキーにより上下

左右に移動するほか、キーボード左側の A, S, D, W キーでもカーソルキーと同様の
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効果がある。 

5.6.7 Display -> Mesh 

Mesh コマンドは、有限要素メッシュの表示・非表示を切り換える。表示される三

角形は有限要素で、三角形の頂点は計算ノードである。図 9 は、サンプル問題の

表示例である。 

Figure 9: A sample .cdg file with mesh displayed 

 

5.6.8 Display -> Node Numbers 

Node Numbers コマンドは、計算ノードの全ての番号の表示・非表示を切り換える。

個々の番号を識別するためには、図 10 で示すように表示を拡大する必要があるか

もしれない。このオプションは、問題を起こしているノードを識別するのにしば

しば役に立つ。また、境界条件を編集するときにも、ノード番号は役に立つ。 
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Figure 10: Using node numbers to identify problem points 

-- 

5.6.9 Display -> Water's Edge  

Water’s Edge コマンドは、モデルの中で水際の境界を表す青い線の表示・非表示を

切り換える。水深が変わるにつれて、この線は乾出と洪水を反映するために更新

される。他の表示オプションのほとんどは水のある範囲だけに対して有効なので、

この線は興味の対象となる地域の境界として表示される。図 11 は、サンプル問題

の water’s edge である。水際線は、デフォルトで表示される。計算の外部境界は常
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に表示され、非表示にできない。境界の色は、境界条件の種類を表す。図 11 で示

すように、赤は流出入のない状態を示し、緑、青、オレンジはそれぞれ流入と 2

種類の流出状況を意味する。 

Figure 11: A sample .cdg file with the water’s edge displayed. 

 

5.6.10 Display -> Contour/Colour 

Contour/Colour コマンドにより図 12 に示す Contour ダイアログボックスが表示さ

れる。このダイアログボックスは、等高線と色分けを制御する。ダイアログの１

番目の項目は、表示するパラメータや変数を選択する。選択されたパラメータは、

ステータス・バー上の３つめの数値としてマウス・ポインタで追跡されるもので

ある。生息場計算が実行されていない状態では、いろいろな生息場指標はゼロで

ある。 

ダイアログの下半分のチェックボックスによって、ユーザーがディスプレイタイ

プオプションのいくつかまたは全てを選択、または何も選択しないということが

できる。 
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Figure 12: The Contour dialog box 

 

Display Contour Lines をチェックすると、Contour Interval に設定した値の間隔で等

高線が引かれる。三角形要素内では線形の内挿が行われるので、要素内を横切る

等高線は直線となる。等高線の値は地図の上には表示されないが、カーソルでポ

イントしてステータス･バーの数値を読めば値を知ることができる。図 13 は、サ

ンプル問題について等高間隔 0.5 で河床高の等高線を描いたものである。ステータ

ス・バーの Bed Elevation 値によって示されるように、カーソル位置の等高線値は

100 である。 

Figure 13: A sample .cdg file with bed elevation contours displayed 
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Display Colour Shading オプションをチェックすると、等高線が色分け（赤は最も高

く、青は最も低い）で表示される。現在、塗りつぶしの色数は 20 色である。図 14

は、サンプル問題の流速を色分け表示したものである。色スペクトルの凡例は、

Display ->Annotation ダイアログから表示させることができる。スペクトルのスケ

ールは、自動的にモデル内のデータの最大値、最小値を与える方法か、手動で最

大値と最小値を与える方法か、どちらかで設定できる。手動でセットされた上下

限以外の値は、白色になる。Clip Colour Shading がチェックされると、色スペクト

ルは水がある部分に対してのみ表示される。クリッピング機能が選択されると、

最大値・最小値は水中にあるノードの最大最小に基づいて設定される。図 14 は、

クリッピング機能が選択された状態である。クリッピング機能がオフならば、色

スペクトルは全ての計算領域に対して表示される 

Figure 14: A sample .cdg file with colour contours used to display velocity magnitude 

 

5.6.11 Display -> Vector  

Vector コマンドは、図 15 で示される Vector Plot ダイアログを表示する。このダイ

アログは、流速または流量のベクトル表示を制御する。ベクトル表示は他の表示

オプションから独立しており、等高線や色分け表示に重ねて表示することもでき

る。図 16 のように、水深を色分けで、流速をベクトルで表示すれば、全体的な流

れ場を視覚化するのに特に効果的である。 
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Figure 15: The Vector Plot dialog box 

 

Figure 16: A sample .cdg file with bed elevation displayed using colour shading and 

velocity magnitude displayed using a vector plot. 

 

Vector Location オプションは、ベクトルがどこに表示されるかを制御する。At Nodes

オプションは、計算結果の良否を評価する時に最も役立つ。On Grid オプションは、

流れ場の画像を作るときによりよい画像を与える。 

Scale の値は、ベクトルの長さを決定する。例えば、Scale を 10 とすると、1m/s の

速さが地図の上で 10m のベクトルとして描かれる。Grid Spacing は、地図上のグリ
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ッド点の間の距離である。Minimum Depth は、速さベクトルを表示する最小水深を

設定する。図 16 では、ベクトルは Minimum Depth 0.02、Scale 5、At Nodes で表示

されている。 

5.6.12 Display-> Bed Contours  

Bed Contours コマンドは、bed ファイルで与えられる河床地形の等高線の表示・非

表示を制御する。bed ファイルが Mesh Edit メニューのなかにある Load Bed File コ

マンドを使って読み込まれている状態で、このコマンドは有効になる。bed データ

が正しく読み込まれたことをユーザーに示すために、bed ファイルが読み込まれる

と、河床等高線はデフォルトで表示される。河床地形の等高線間隔を変えるため

のセッティングは、Option メニューからアクセスできる Mesh Edit Options ダイア

ログボックスにある。 

5.6.13 Display -> Annotation  

Annotation コマンドは、Annotation Options ダイアログボックス（図 17 で示される）

を表示する。このダイアログは、地図に関する凡例と軸の情報の表示を制御する。

スクリーン全体に地図を表示するために、デフォルトでは全ての Annotation はオ

フである。特に印刷するときに、Annotation の情報は役に立つだろう。Annotation

オプションは自由に選択・非選択を選ぶことができる。図 18 は、全ての Annotation

オプションをオンにして図 16 のサンプル問題を表示したものである。 

Figure 17: The Annotation Options dialog box 
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Figure 18: A sample .cdg file with annotation displayed. 

 

Axes オプションによって、領域を囲う矩形の座標軸がディスプレイで示されるよ

うになる。 

Colour Legend は、パラメータへの色スペクトルのマッピングの判例と、パラメー

タ名を表示する。 

Distance Scale は、距離目盛を表示する。 

Vector Scale は、ベクトルの長さの凡例を表示する。 

Title オプションが選択されると、ディスプレイの上部にタイトルが表示される。 

Inflow and/or Outflow Discharge を選択することにより、ディスプレイの上部に流入

流量、流出流量の値が表示されるようになる。 

最後に、Time オプションは、現在のモデル時間を表示する。 

5.6.14 Display -> Dump nodal csv file  

Dump nodal csv file コマンドは、River2D モデルからのオプション出力である。メ

ッシュ内の全てのノードごと１行のデータが csv ファイルとして出力される。各行

には、ノード番号、x 座標、y 座標、そして１つのパラメータ値含んでおり、それ

らはコンマによって区切られている。パラメータは、contour/colour ダイアログに

おいて選ばれるものであって、ウインドウの下のステータスライン上で指示され

ているものである。.csv 形式による出力は、スプレッドシートや GIS プログラムに
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よって River2D の結果をさらに処理する時に役立つ。 

5.6.15 Display -> Dump grid csv file  

出力される点がグリッド上であるという点を除いて、Dump grid csv file コマンドは

Dump nodal csv file コマンドに似ています。ファイル形式は、nodal csv ファイルと

全く同一である。ダイアログボックスでは、出力範囲の左下座標(x1、y1)と右上座

標 (x2、y2)をユーザーが与える。デフォルト値は、実際のメッシュ点の領域のち

ょうど外側に設定されている。メッシュ外部の格子点には、負のノード番号とパ

ラメータ値 0 が割り当てられる。point spacing value は、x,y 方向の格子間隔である。

格子は、x1、y1 の線から始めて、x2、y2 より少ない最後のグリッドラインまで及

ぶ。 

5.6.16 Display -> Extract points to csv file  

Extract points to csv file コマンドは、出力すべき点が既存の.csv ファイルに既に定義

されるという点を除いて、dump nodal csv file コマンドに似ている。入力されるフ

ァイル形式は、.csv file オプションのすべての出力フォーマットと同一である。一

度グリッドやセクションを定義すれば、このオプションを用いて同じ点で異なる

変数の値を取り出したり、異なる流量での同じ変数の値を取り出したりできる。

もう一つの使い方は、異なるメッシュを用いて計算した同じ場所の値を比較する

ことである。ダイアログボックスには、入力.csv ファイルと出力.csv ファイルを指

定する。 

5.6.17 Display -> Extract section to csv file  

Extract section to csv file コマンドは、出力する点が 2 つの端店によって定義される

線の上に置かれること以外は、dump grid csv file コマンドに似ている。ファイル形

式は、他の csv ファイルと同一である。ダイアログボックスには、始点(x1, y1)と

終点(x2, y2)の座標を入力する。メッシュの中にない線上の点に対しては、負のノ

ード番号とパラメータ値０を割り当てる。point spacing value は、線に沿った間隔

増加量である。点のセットは x1、y1 の点で始まり、終点より手間で最後に増加し

た点まで及ぶ。線は、どんな方向に定義してもかまわない。端点が、メッシュの

範囲内である必要はない。 

プロフィールラインは、個々に取り出した線のセグメントファイルをスプレッド

シート上で連結することで描くことがでる。一度連結されたファイルを使って

Extract points to csv file コマンドを実行すれば、同じ場所の他のパラメータを取り

出すことができる点に注意されたい。 
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5.7 流体力学モデルの操作 

River2D の流体力学計算コンポーネントは、図 19 の中に示されている Flow メニュ

ーの下にあるコマンドを通して制御される。 

Figure 19: The River2D Flow Menu 

-- 

流体力学モデルは実際には常に非定常計算を行っているが、任意の次点でそれは

定常と非定常という2つの異なるモードで動くことができる。Flowメニューの個々

のコマンドの詳細を記述する前に、2 つのモードの解析過程を概観しておくことは

有用だろう。 

5.7.1 定常モードの解析課程 

定常モードにおいて、定常状態の解に収束させるために使用されるプロセスは、

実際には準非定常プロセスである。したがって、反復は時間増分によって緩和さ

れる。また、最終時間はシミュレーションを終了するために使用される。ここで

の目的は、任意の流況下で安定状態を保ったまま、できるだけ少ない計算で定常

状態に達することである。 

基本的アプローチは、第一に非常に短い時間ステップで計算開始することである。

これは初期条件では最終的な平衡と大きく異なり、流れの変化率が非常に高いか

もしれないからである。解は定常状態へ進行するので、通常、変化率は減少して

ゆき、そうなればより長い時間ステップに設定することが可能になる。開水路流

れの潮津波や跳水などの波のような性質のため、最終的な定常状態への収束の進

行は一定ではないかもしれない。 

プログラムロジックは、次のように進行する。各時間ステップの終わりに、全体

の相対的変化が計算されて、目標となる変化量と比較される。全体の相対的変化

は、すべての変数の変化の 2 乗和の平方根をすべての変数の値の 2 乗和の平方根

で割ったものと定義される。実際の変化が目標となる変化の 1.25 倍未満であるな
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らば、現在の繰り返しステップは受け入れられ、次のステップに進む。次のステ

ップのための時間増分は、前の時間ステップと実際の変化と目標変化の比率の積

として計算される。この比率が 1.5 を超えるときは、1.5 に設定される。時間が定

義された終了時間より少ない限り、次の時間ステップが計算される。 

実際の変化が目標変化の 1.25 倍を超える場合、現在の繰り返しステップは却下さ

れる。目標変化と実際の変化の比率に失敗した時間ステップの半分を掛けて得ら

れた値を新たな時間ステップに設定して、再度前回の反復が再試行される。この

プロセスは、次のステップへの移行が受け入れられるまで、時間ステップを小さ

くしながら２～３回繰り返されるかもしれない。 

ほとんどの場合、時間ステップは最終的には結局大きくなり、解は安定状態に急

速に接近するだろう。総流入量と総流出量は、解が最終的な解にどれくらい近づ

いたかを示す指標である。計算の進行につれ、解が互いに近よるので、これらの

数は一定で所定の流量にほぼ等しくなるはずである。原理的には、これらの値は

正確に等しくなければならない。しかし、コンピュータによる計算はあくまで概

算であり、境界の近くでの離散化の程度に依存する。 

定常状態に達するのに要する計算時間は、問題によって変化する。流体を粒子と

考えたときに、その粒子が計算区間を通過するのに要する時間が計算時間の目安

になる。モデル上での経過時間がこの通過時間の２，３倍程度で定常状態に達す

るのが普通である。 

5.7.2 非定常モードの解析課程 

非定常シミュレーションでの目的は、特定の流況イベントの持続時間全体に渡っ

て正確な計算結果を得ることである。これは、シミュレーションにおけるあらゆ

る時間ステップで、式の支配している非線形のシステムの正確な解を必要とする。

モデルの中で、非線形システムは線形システムに近似され、指定の精度レベルを

保つよう Newton-Raphson 法による繰り返し計算によって解かれる。定常モードで

は、時間ステップあたり一度だけ Newton-Raphson を実行するのに対し、非定常モ

ードでは、すべての時間ステップで解の収束が一定レベルに達するように制御さ

れる。 

非定常モードのシミュレーションに先立って、境界条件と初期条件が指定されな

ければならない。常流を仮定して、流入セクションで流量、流出セクションで水

面高を指定する。非定常分析では、これらの条件しばしば、流入セクションでは

流量のハイドログラフ、流出セクションでは水面高のハイドログラフの形式で入

力される。水面高ハイドログラフが利用可能でないならば、水位－流量曲線を利
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用するのも現実的代替案となる。 

初期条件は、計算領域のあらゆる点で指定されなければならず、シミュレーショ

ンしたいイベントの直前の流況を反映していなければならない。初期条件は、非

定常シミュレーションに先立って、定常状態の境界条件を使って定常モードで計

算を行っておくことによって設定することができる。あるいは、適切な境界条件

を与えて任意の初期条件から非定常計算をスタートし、最初の部分の計算結果は

無視するという方法もある。 

時間ステップの選択は、現象の速度と解に要求される解像度のレベルに依存する。

空間的に詳細な解が必要なら、小さな三角要素を使用するのと同様、時間的に詳

細な解が必要なら、小さな時間ステップを使用する必要がある。小スケールの流

れを非定常で正確にモデル化するためには、クーラン数は１より小さくなければ

ならない。クーラン数は以下で定義される。 

 (49) 

ここで、Vw は現象の速度Δt は時間ステップ、Δx はメッシュ間隔である。三角要

素の大きさは一定ではないため、メッシュ間隔が領域中で変化するので、クーラ

ン数は領域を通して同じ値ではない。それに加えて、現象の速度も変化するので、

クーラン数は時間によっても場所によっても変化することになる。このため、適

切な時間ステップを決定するためには、上記の式の中の速度とメッシュ間隔の適

切な評価値を用意しなければならない。 

洪水波のような、大スケールの現象をモデル化しているならば、より大きいクー

ラン数、より大きい時間ステップを使用することができる。しかし一般に、時間

ステップを大きく設定すると、非線形の不安定性が顕著になる恐れが大きくなる。 

モデル実行が始まると、求解プロセスは次のように進む。各 Newton-Raphson の繰

り返しの終わりに、各未知数（水面高、ｘ、ｙ流速）の値が、前の時間ステップ

のそれぞれの値と比較される。変数の全ての変化が承認される変化より少ないな

ら、その時間ステップは受け入れられる。次のステップの時間増加は、前の時間

ステップ（この値がユーザー指定の時間ステップ増加を上回らない限り）の 2 倍

として計算される。現在の時刻がシミュレーション終了時間より小さければ、次

の時間ステップの解が評価される。 

変数のいずれかの変化が 1 つの Newton-Raphson 繰り返し終了後に承認される変化

より大きいならば、承認される変化より少なくなるまで、あるいは設定された最
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大繰り返し数に達するまで、次の Newton-Raphson 繰り返しが実行される。承認さ

れる変化基準が満たされる前に繰り返しの最大数に達すると、その時間ステップ

は却下される。その場合には、新しい時間ステップとして先の値の１／２が設定

される。場合によっては、時間ステップがかなり小さくなるまでその時間ステッ

プが却下され続け、その後進行しはじめることもある。 

非定常イベントのために必要なモデル時間は、その現象が計算領域全体に伝播す

る時間に支配される。またその時間は、境界条件を必要な時間分設定するために

はあらかじめわかっていなければならない。また同時に、時間ステップにも依存

する。 

5.7.3 Flow -> Run Steady 

Run Steady コマンドは図 20 で示される Run Steady ダイアログボックスを開く。 

このコマンドは、定常モードでの流体力学モデルの実行を制御する。 

をクリックして明示的に閉じるまで、このダイアログボックスは開いたままと

なる。 

流体力学モデルはバックグラウンド・プロセスとして実行される。従って、モデ

ル実行中でも表示設定の変更やその他の操作を行うことができる。 

このダイアログボックスで設定する値については、「定常モードの解析過程」の節

で一通り説明されている。また、それらの使用法は以下で詳述される。 
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Figure 20: The Run Steady dialog box 

 

Present time 値は、現在計算を実行している、あるいはそこまで実行して停止した

モデル時間を表す。この値は、以降の実行のスタートの前のリセットすることも

できる。 

Final time は、流体力学モデルの実行が停止する時間である。実際には、Present time

が Final time を上回った時点で実行が停止する。 

Time increment は、現在の時間ステップである。それは、実行開始前に設定するが、

もし長すぎればプログラムが自動的に調節する。繰り返しを続けると、この値は、

通常着実に増加する。時折、それは劇的に減少して、それから再び徐々に増加し

はじめる。こうした現象が見られる場合には、境界条件やメッシュに関する問題

があるかもしれない。 

Max time increment は、許容される最大時間ステップをユーザーが設定するための
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ものである。これは、収束プロセスを制御するもう一つの手段となる。 

Solution change は、最新の時間ステップについての変数の全体の相対的変化である。

この値と Goal solution change(目標となる変化量)との関係が、時間ステップの増加

速度を支配する。一旦最大の時間ステップに達した後は、Solution change それ以降

の繰り返しごとに小さくなっていくはずである。これが十分に小さく（およそ

0.00001）なれば、解が収束したと考えられる。 

場合によっては、solution change が 0.001 程度のオーダーの比較的小さな値に達し

た後、以降の時間ステップではなかなか減少しなくなることがある。通常、これ

は流れ場の 1 つ（または時々より多く）の点で、小さな持続的な振動が発生して

いることを示す。しばしば振動は浅いノードにおける乾出と冠水の繰り返すと関

連している。もう一つの可能性としては、障害物からの小さな渦巻きの周期的な

発散が考えられる。流出境界で発生する渦も安定し難いものである。解を安定さ

せるための対策としては、数値的ヤコビ行列への変更（下記参照）、渦拡散係数の

変更（下記参照）、問題発生域のメッシュの精細化、流出境界の修正、などがある。

また、振動による変動が要求された精度の範囲内とみなさるなら、振動している

解でも許容範囲と言える場合もある。 

Goal Solution change は、変数の全体の相対的変化のユーザーが指定する目標値であ

る。この値が大きいほど、使用される時間ステップは大きく、そして、うまくい

けば、定常状態に達する繰り返し回数も小さくなる。しかし、あまり大きくする

と非線形の不安定性は起こりやすくなり、結果として時間ステップ短縮が頻繁に

発生することもある。 

Log file name は、プログラム実行の記録が書きこまれるテキストファイルの名前で

ある。この記録は、繰り返し毎の時間、時間ステップ、解の変化からなる。反復

的なソルバーが使われる場合には、ソルバーのパフォーマンスに関する追加の情

報がログに追加される。繰り返しが否定された場合には、問題の所在を絞り込む

助けになる追加の情報も書きこまれる。ログファイルは常に追加され、決して上

書きされない。デフォルトの名は steady.log であり、現在の.cdg ファイルと同じデ

ィレクトリにある。 

Total Inflow と Total Outflow は、それぞれ、流入と流出境界を通過する流量を表す。

定常状態の流況の 1 つの特徴は、これら 2 つの値が等しくなければならないとい

うことである。実際には、近似誤差のために、それらが正確に等しくなるわけで

はなく、わずかな違いがある。定常状態に解が近づいていく様子は、これらの値

の変化を追跡することで観察できる。 
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Update display every time steps は表示が更新される頻度を設定するのに用いられる。

画面出力にも若干のプロセッサ時間を消費するので、計算速度を稼ぐためには表

示を更新する頻度を少なくすることを考えたほうがよい場合もあるだろう。 

Current step #は、最新の実行開始からの時間ステップの繰り返し回数を表示する。 

必要なパラメータを入力したあと、Run ボタンをクリックすることで計算が開始さ

れる。モデルが実行されている間、ボタン・キャプションは Stop に変わる。モデ

ルの実行中に Stop ボタンを押すと、次の繰り返しステップの終わりで停止する。

繰り返しが終わるのを待っている間、キャプションは Stopping に変わる。再び Run

ボタンを押せば、計算を再開することができる。計算途中で実行を止めてパラメ

ータ値を変更するといったことができる。 

5.7.4 Flow -> Run Transient  

Run Transient コマンドにより図 21 の Run Transient ダイアログボックスが開く。 

このダイアログは、非定常モードでの流体力学モデルの実行のモニターと制御を

行う。 

右上の「閉じる」ボタンをクリックして明確に閉じるまで、このダイアログボッ

クスは開いたままである。 

定常計算と同様、非定常計算もバックグラウンド・プロセスとして実行される。 

つまり、モデルの実行中にも、表示設定や他の操作を行うことができるわけであ

る。 

このダイアログボックスに表示されている値は、既出の「非定常モードの解析過

程」の章で一通り説明されている。それらの特定の使途は以下で説明される。 
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Figure 21: The Run Transient Dialog Box 

 

Present time 値は、モデルが現在実行中の時間、あるいは停止したときの時間であ

る。定常モードとは違い、非定常モードでモデルを使うときには時間はきちんと

指定しなければならない。現在の時間は、入力ハイドログラフ（流量や水面高）

に基づいてモデル境界条件を設定し、特定の時間に対して適切に出力を生成する

ために使われる。シミュレーションの初めに時間についてのみリセットすること

を薦める。 

Final time は、流体力学モデルの実行が停止する時間である。定常モードの場合の

ように、Present time が Final time を上回ると実行が停止する。入力ハイドログラフ

は Final time の指定時間より長めに準備しておくことが推薦される。ハイドログラ

フが Final time より短ければ、それ以後の境界条件はハイドログラフの採集時間の

値から取られる。（境界条件のファイルフォーマットは以降の節で述べられる。） 

Time step increment, Δt は、現在の時間ステップである。この値は、Goal Δt を越え

ないよう実行前に設定する。プログラムは、指定された許容誤差を満たすよう、

時間ステップが終わる毎に自動的に Δt を増減する。モデルがスムーズに実行され
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ていれば、この値は Goal Δt に近い値になる。 

Goal Δt は、シミュレーションのためのユーザーが指定する時間ステップである。

それは、モデルが取りうる最大の時間ステップでもある。この値は、ファイル出

力が発生する時を定義するためにも使われる。例えば、モデルが Goal Δt = 2 に設

定されていれば、たとえ実際の時間ステップは安定性を維持するために 2 未満に

自動調整されていても、解は t = 2、4、6、8…etc の時に出力される。 

# of iterations per Δt は、単にどれくらいの Newton-Raphson 繰り返しがこの前ステ

ップで収束するまでに必要だったかということを示すインジケーターである。 

Max # of iterations per Δt は、各時間ステップあたりの Newton-Raphson 繰り返しの

上限をユーザーが設定するものである。解の変化率が許容範囲に達する前に、繰

り返し数がこの値に達すると、その時間ステップは棄却され、Δt は減じられる。 

Solution tolerance は、時間ステップ毎に解の収束を判定するためにユーザーが指定

する許容範囲の値である。この許容範囲は、メッシュのノードのすべての変数の

うちの最大の変化で判定される。許容範囲を大きく取れば、時間ステップあたり

の繰り返し数は小さくなる。しかし、正確度は低下し、解が不安定になるかもし

れない。許容範囲を小さくすると、時間ステップあたりの繰り返し数は多くなる。

Newton-Raphson 法は２次の収束をするので、繰り返しが少し多くなるだけで許容

範囲は数オーダー小さくなるかもしれない。 

Implicitness θは、モデルが支配方程式系を解く方法を制御するユーザー指定値で

ある。0 に設定すれば完全に陽的に解き、1 に設定すれば完全に陰的に解く。支配

方程式に対する解としては半陰解法（すなわちθ= 0.5）のとき最も正確となる。

しかし、θ= 1.0 の方が解は安定する。θが 0.5 未満では不安定になるのでしない

ほうが良い。θの設定に関する経験則は、次の通りである。微視的な流れをモデ

ル化しているならば、クーラン数が１になるよう Goal Δt を設定し、θ= 0.5 とす

ればよい。他方、洪水波のような大規模な現象のおおまかな傾向に興味があるだ

けであるならば、Goal Δt を大きく取り、θ= 1.0 にすれば良い。これは、大きい

時間ステップを用いるとθ= 0.5 により生ずる精度向上効果が不明瞭になるからで

ある。完全陰解法の解はよりなめらかで、より速く収束する傾向がある。 

Log file name は、プログラムの実行記録が書かれるテキストファイルの名前である。

各時間ステップの Newton-Raphson 繰り返し数を含む以外は、定常モードで出力さ

れるものと本質的に同じものである。そのデフォルト名は transient.log で、現在

の.cdg ファイルと同じディレクトリに置かれる。 

Total Inflow と Total Outflow は、モデルに流入、流出する全流量を示す。非定常解
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析においては、これらは非定常の境界条件によって変化する。 

Update display every time steps は、表示の更新頻度を設定するために用いられる。

ディスプレイへの描画はプロセッサ時間を消費するので、表示の更新頻度を制限

することが望ましいかもしれない。 

Output Options ボタンは、Transient Output Options ダイアログボックスを開く。こ

のダイアログによって、非定常解析の出力をカスタマイズすることができる。こ

のダイアログの詳細は、Option Setting Operations の節で説明される。シミュレーシ

ョン開始に先立って、必要な出力形式を選択しておかねばならない。 

パラメータの全てを適切に設定した後、Run ボタンによって解析プロセスを開始す

る。モデル実行中、ボタン・キャプションは Stop に変わる。モデル実行中に Stop

ボタンを押せば、現在の時間ステップが終了した後停止する。時間ステップの終

了を待つ間、キャプションは Stopping に変わる。解析は、もう一度 Run ボタンを

押すことで再開できる。ただし、それまでの計算でΔt が Goal Δt よりも小さい値

であった場合、計算を再開した時の出力の時間間隔はそれまでのものと違う場合

がある。 

5.7.5 Flow Boundaries 

モデルでは、境界条件は各境界要素に設定されなければならない。flow boundary

は、境界条件を適用するための便利なフォーマットである。例えば、流入セクシ

ョンは、複数の境界要素から成るかもしれない。各境界要素に対して境界条件を

設定するのは非常に厄介である。要素の指定が必要なだけでなく、それぞれの要

素毎に全体の流入量をどう配分するかを決めなければならない。flow boundaryは、

ユーザーが個々の要素に境界境界条件を設定するのではなく、ひとまとまりの境

界のセクションに対して境界条件を設定できるようにするものである。flow 

boundary は流れのない境界である no flow boundary と区別する意味でそう呼ばれて

いる。flow boundary を定義するために必要な情報は、以下のとおり。すなわち、

Starting node（境界に沿った最初のノード）、Ending node（最後のノード）、type of flow 

boundary（境界の型：inflow（流入）か outflow（流出））、および、流量などの情報

である。flow boundary は、常に boundary の左側に計算領域がくる方向に定義され

る。したがって、外部境界は反時計回り、内部境界は時計回りに定義することに

なる。境界条件の設定には、Flow メニュー下の Edit Flow Boundary と Define New 

Flow Boundary コマンドが利用できる。 

5.7.6 Flow -> Edit Flow Boundary  

この命令によって、既存の flow boundary を編集することができる。コマンドを選
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択した後、流入・流出境界を選ぶためにマウスで既存の flow boundary をクリック

によって指定する。すると、図 22 の Edit Flow Boundary ダイアログボックスが開

く。 

Figure 22: The Edit Flow Boundary Dialog 

-- 

境界の範囲は、ダイアログの上部の Starting node, Ending node を書き換えることで

変更することができる。また、境界条件のタイプは、適切なラジオボタンを選ぶ

ことによって修正することができる。選択肢は、Inflow Condition(流入条件)、Outflow 

Condition(流出条件)、または No Flow Condition（流入出なし）である。 

流入条件に対しては、ユーザーは Fixed Discharge(固定流量)か Time Varying 

Discharge(時間変動流量)かを指定しなければならない。固定流量のためには、一つ

の値だけが必要である。時間変動流量に対しては、流入ハイドログラフが収めら

れたファイルを指定する。 
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流出条件については、ユーザーは 4つのオプションを選択できる。Fixed Elevation(固

定水表面高 )、Time Varying Elevation(時間変動水面高 )、Stage-Total Discharge 

Relationship(水位流量曲線)、Depth-Unit Discharge Relationship(水深-単位流量曲線)

である。 

最初の 2 つのオプションは、流入オプションと似ている。固定水面高は単一の値、

時間変動水面高はその情報が収められたファイル名を指定する。時間変動水面高、

時間変動流量のファイルの例を表 1 に示す。両方ともテキストファイルであり、

拡張子で区別する。流量ファイルの拡張子は.bcq、水面高ファイルの拡張子は.bch

である。 

第 3 のオプションも、流量とそれに対応する水面高の表形式のファイルであり、

ダイアログにはファイルの場所を指定する。水位流量曲線ファイル名は、ハイド

ログラフ・ファイルと同じ形式であり、拡張子は.bcr である。水位流量曲線ファイ

ルの例は表 1 に含まれている。 

これら３種類のファイルはいずれも、”(“を含まない説明文をファイル冒頭に必要

な行数だけ置くことができる。表の行数には制限はない。唯一の必要条件は、デ

ータが表 1 で示されるように括弧で囲まれていなければならないということであ

る。 
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Table 1: Format for Boundary Condition files 

 

 

与えられた点では、やがてこれらの流出状態の３つは流出境界の水面高の値に収

束していく。流出境界全体に同じ値に収束させることが困難なケースもあり得る。

この場合には、４つめのオプションである深さ-単位放出曲線が役立つ場合がある。

このオプションは、流出境界の各境界要素を堰のように扱う。式は流出区間全体

ではなく、個々の要素レベルに適用されるので、要素毎の流量に対する水面高を

求めることができる。この場合には、流出境界の個々の要素の水面高が同じでな

い場合がある。このタイプの境界条件は、下流の境界が河川の屈曲部に設定され、

水面高が左右で同じではないような場合に特に便利である。 
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No Flow Condition が選択された場合、境界条件の位置の設定も含めた全ての条件

が削除される。そのことはダイアログにも記述されている。削除した flow boundary

は、以下の節で説明される Define New Flow Boundary コマンドで新たに定義するこ

とによって復元できる。 

5.7.7 Flow -> Define New Flow Boundary  

このコマンドを選択すると、Define New Flow Boundaryダイアログボックスが開く。

Edit Flow Boundary コマンドで既存の flow boundary を編集できるのに対し、このコ

マンドでは新しい flow boundary が作成できる。Starting node と Ending node には開

始点と終点のノード番号を設定する。新しい flow boundary のノード番号を決定す

るためには、Display->NodeNumbers コマンドでノード番号を表示させるとよい。 

Figure 23: The Define New Flow Boundary Dialog 

 

5.7.8 Flow -> Reset Initial Conditions  

このコマンドにより、初期条件をリセットされる。定常解を得るための反復手続
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きにおいてすべてのノードにおける変数の初期値が必要となる。必要な値は、水

表面、x, y 方向の流速である。このコマンドが選択されると、流入境界の水面高の

入力が求められる。この値を用いて、領域全体の初期水面高が計算され、設定さ

れる。この入力値と、流出境界の水面高から初期の水面勾配が計算される。この

水面高は、有限要素メッシュを用いて Laplace 方程式の数値解に基づいて評価され

る。この初期条件は R2D_Mesh で計算される初期条件とはいくぶん異なるという

ことに注意する必要がある。水面勾配を求めた後、流出流量はゼロにリセットさ

れる。 

5.7.9 Flow -> Check Memory  

直接解法が選択されると、各反復計算過程で非常に大きいヤコビ行列が生成され

る。この行列は、ノードごとに３つある未知変数全ての相互作用を表している。

疎大行列記憶スキーム（スカイライン記憶法）が使われるので、この行列は大変

大きなものになり、行列を格納するメモリ容量が扱えるノード数を支配する。ヤ

コビ行列のサイズは、ノード数に加えて、メッシュの複雑さにも依存する。 

ヤコビ行列に対するメモリは、最初の繰り返し時に割り当てられる。メモリが割

り当てられた後であれば、Check Memory コマンドによって、図 24 のように、ノ

ード数、要素数、割り当てられたメモリ量を示す情報ボックスが表示される。情

報ボックスには、現在どの解法が使用されているかも表示される。割り当てられ

るメモリが物理的な RAM 容量より大きい時には、W95/98/2000/ME/NT/XP に備わ

るダイナミックメモリ管理によってハードディスクがメモリとして利用される。

しかし、ハードディスク・アクセスは大変遅いため、解が得られるまでの時間は

大変長くなる。 

Figure 24: Check Memory information box for the direct solver 

-- 

反復解法はヤコビ行列を使わない。このため、必要なメモリが小さいことがこの

解法の主な利点である。直接解法と同様、反復解法に必要なメモリ容量も最初の

繰り返しステップで割り当てられる。反復解法についても、最初の繰り返し以降



 

 67 

は図 25 のように Check Memory コマンドで情報ボックスが表示される。 

Figure 25:Check Memory information box for the iterative solver. 

 

5.7.10 Flow -> Cumulative Discharge  

このコマンドは、計算領域全体にわたる累積流量（もしくは流れ関数と呼ばれる）

を計算するために使用される。このコマンドが選ばれると、計算が終了していれ

ば、図 26 で示すように、累積流量がカラースペクトルで自動的に表示される。累

積流量は、図 12 で示すように、Contour ダイアログボックスで指定可能なディス

プレイ・パラメータのうちの 1 つである。したがって、計算が終了していれば、

このパラメータの表示は消してもよい。水深、流速、流量といった他の流体力学

パラメータと違い、累積流量値は他の流体力学パラメータが更新されるときに更

新されるというわけではない。したがって、流況が変化した場合には、このコマ

ンドは再度呼び出される必要がある。 

累積流量は水路内での流れの分布を表現する方法の１つとして使用することはで

きるが、River2D における主な目的は境界部の抽出プロセスでの利用である。流れ

関数によって定義される流線は、流れのない境界の位置を抽出するための一つの

方法として利用することができる。モデルが収束に達していない場合、計算され

た流線は定常解における流線を表していない場合がある。従って、もし累積流量

を境界抽出のために使用するなら、累積流量を計算する前にモデルが定常状態に

達していることを確かめる必要がある。 
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Figure 26:A sample .cdg file with cumulative discharge displayed. 

-- 

このコマンドはベータ版の段階なので、きちんと計算されているかどうか確認す

る必要がある場合がある。確認方法は以下のとおりである。 

まず、扱う問題が１つの流入境界だけを持つならば、River2D は計算領域の累積流

量を簡単に計算することができる。累積流量を計算するために必要な境界条件は、

外部の計算境界に沿ってぐるりと調べることで設定される。境界条件を正しく設

定するために、モデルは流入境界と流れなし境界の境目を出発点として、反時計

回りに計算領域を一回りしなければならない。複数の流入境界がある場合は、モ

デルが出発点として選ぶことができるノードは複数存在する。残念なことに、流

入境界と流れなし境界の境目の全てが、境界条件の出発点として使用できるわけ

ではない。反時計回りに現れる次の遷移ノードが、流れなし境界から流出境界に

遷移するものである場合だけが出発点として使うことができる。したがって、問

題の領域に複数の流入境界部分があるならば、解法が正しく進行するよう、ユー

ザーは適切な出発点となるノードを選ぶ必要がある。 

複数の計算境界（すなわち 1 つの外部境界に加えて一つ以上の内部境界）を持つ

場合には、.cdg ファイルの中における境界条件の出現順序は正しい累積流量の計算

にとって大変重要である。計算境界は、境界要素のリストとして記述されている。

累積流量を正しく計算するためには、境界要素のリストにおいてまず最初に外部

境界の定義が置かれていなければならない。境界要素リストの中の境界のオリジ

ナルの順序は、メッシュが作成されたときに定義された順番となる。外部境界が

リストの最初にない場合は、テキスト・エディタで順序を変える必要がある。リ

ストの中の外部境界の場所がわからない場合は、それは River2D でノード番号を調

べ、テキスト・エディタでリストを検索すればよい。 
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5.8 メッシュ編集オプション  

メッシュ編集はもっぱら R2D_Mesh で行うが、River2D の中でメッシュに小さな変

更（特に精細化）を加えることができることが非常に有用な場合がある。また、

大きな計算領域の中から一部を切り出して、別に扱いたい場合などもある。これ

らの理由のために、メッシュ編集機能が River2D に組み込まれている。Mesh Edit

メニューでユーザーが利用可能なメッシュ編集操作を図 27 に示す。 

Figure 27:The River2D Mesh Edit Menu. 

-- 

5.8.1 Mesh Edit->Load Bed File…  

計算メッシュに変更を加えるためには、メッシュを作成するために使用されたオ

リジナルの河床地形ファイルを River2D にロードしなければならない。これは、

Load Bed File コマンドで実行される。.bed 拡張子のフィルタつきの標準の Open File

ダイアログが開く。新しい河床ファイルをロードすると、それまでロードされて

いて河床データは置き換えられる。 

Load Bed File コマンドは、計算メッシュの河床高や粗度を変更するためにも使用で

きる。最初に、メッシュを生成するために使われた.bed ファイルを、R2D_Bed や

テキスト・エディタで修正する。その後、Load Bed File コマンドで編集された.bed

ファイルを読み込めばよい。メッシュの全計算点の河床高と粗度は、修正された

河床ファイルから読み取られる。河床高や粗度を変更することは、2 つの意味で役

立つ場合がある。第一は、モデルキャリブレーション時に部分的に粗度を変える

ことで、測定値への近似度が高まる場合がある。第二は、水路地形の変化の影響

を調べることである。 
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5.8.2 Mesh Edit->Extract Boundary…  

あるメッシュを用いて定常状態に至るまで計算を実行したあとで、一部の場所に

ついてもっと詳細に解析した方が有益だということがわかってくることがある。

Extract Boundary コマンドは、計算領域の中から一部の領域を取り出し、より精細

なメッシュを作成できるようにするものである。 

このコマンドは、境界抽出過程で流れなし境界を定義するために流線（それは、

流れの内部における理論上の流れなし境界である）の概念を使う。流れにの中に

流線を描くためには、流れ関数または累積流量が領域全体に渡って得られていな

ければならない。したがって、境界を抽出する前に、累積流量を計算しなければ

ならない。これは Flow メニューの Cumulative Discharge コマンドを選ぶことによ

って達成される。 

累積流量が計算されれば、Extract Boundary コマンドが実行可能状態となる。この

コマンドを選択すると、図 28 に示す Extract Boundary ダイアログが開く。 

Figure 28: The Extract Boundary Dialog Box 

-- 

この時点では、単純な境界だけが抽出されている。すなわち、１つの流入セグメ

ントと、１つの流出セグメント、２つの流れなし境界セグメント（右側と左側）

である。 
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流れなし境界は、Streamline(流線)、Depth contour(等深線)、または Computational 

boundary(計算境界)によって定義することができる。流線が流れなし境界を定義す

るために使われるならば、図 28 の Left boundary で示すように、流線を表す累積流

量値を指定しなければならない。領域の流量があまり低いケースでは、流線はあ

まりなめらかでななく、流線による流れなし境界はあまりよくないかもしれない。

この場合、等水深線（例えば水際線（0.02m の等深線））を、代わりの流れなし境

界として使うことができる。等深線を流れなし境界の定義に使う場合は、図 28 の

Right boundary の定義で示されるように、水深値を指定しなければならない。計算

境界は流れなし境界なので、それを流れなし境界の定義に使用することができる。

計算境界を選択した場合には、値は必要でない。 

流入と流出境界は、ユーザーが指定する点に基づいて決定される。これらの位置

は、流れなし境界を定義するために使われている要素（流線、等深線など）が流

入部と流出部の間で分岐の無い連続する線となるようなものでなければならない。

また、流入部は、そこを横切る流れの大部分が流れなし境界と平行である場所に

選定しなければならない。これは、流入境界に対して流れは垂直であると仮定さ

れるので、このように流入部を設定することが実際の水の流れを再現するために

は重要だからである。流出部は、下流境界での安定した水面高境界条件が有効と

なるよう、水面高が境界の左右で比較的一定となるような位置に選択すべきであ

る。 

定義される点は、左右の流れ境界の間に位置するように選択しなければならない。

加えて、これらの点は、流速がはっきりしており、設定する区間での流向を代表

するような場所に選ばれなければならない。これは、定義した点の流速ベクトル

が定義されている区間の strike を決定するために使われるからである。Node 

Spacing for Boundary は、新しい境界のノード間隔を指定するために使われる。ノ

ード間隔にはゼロより大きい値を指定しなければならない。 

境界抽出プロセスに関わる値はダイアログボックスですべて指定するため、流れ

なし境界や流れ境界を示す点を入力するための値は、ダイアログボックスを開く

前に決めておかなければならない。流線または等深線によって流れなし境界を定

義するための値を選択するためには、等深線図や累積流量図、あるいはそれらの

カラーマップやカラースペクトル表示を利用すればよい。これによって、ユーザ

ーは流線や等深線の位置を判断することができる。左右の境界位置を視覚的に決

定すれば、具体的な値はマウスをその位置にもっていき、ステータス・バーの値

を読むことで求めることができる。また、マウスとステータス・バーを使って、

流入・流出境界を定義するための点の x，y 座標を求めることができる。 
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全てのパラメータをダイアログボックスに入力し、OK ボタンを押せば、標準保存

ダイアログボックスが開くので、境界をファイルに保存する。境界は、メッシュ・

ファイルと同じフォーマットで.msh 拡張子のついたファイルに保存される。メッ

シュ・ファイルは、境界を定義するために使われるノードと境界要素に加えて、

流入・流出境界条件を含む。流入境界部分での流量値は、流入境界を定義するラ

インの端点の累積流量の差をとることによって決定される。流出部分では、固定

水面高境界条件が設定される。この境界条件の値は、流出境界を定義するライン

の 2 つの端点間の平均水面高となる。したがって、水面高があまり一定とは言え

ない断面に流出境界を設定すると、下流端の境界条件は流況を反映しないことに

もなりかねない。島のような内部境界を含む区間からの抽出では、出力に内部境

界が含まれないことに注意する必要がある。内部境界が必須であれば、それらは

別途メッシュ・ファイルに追加しなければならない。この境界に基づいてメッシ

ュを作成するためには、元になったメッシュを作る時に使用した.bed ファイルを

R2D_mesh で開かなければならない。.bed ファイルをまず開けば、新しい境界ファ

イルを開くことができるようになる。これによって、新しいメッシュの作成作業

が可能になる。一旦メッシュの作成が終了すれば、cdg ファイルとして保存し、改

めて River2D で解くことができる。 

5.8.3 Mesh Edit->Mesh Merge  

Mesh Merge コマンドは、2 つのメッシュの情報を結合するために使われる。この

コマンドは、現在表示されている主メッシュに、ファイルに記録された副メッシ

ュの情報を付け加える。メッシュは、2 つの方法で合成できる。 

1． Region Replace： このオプションは、副メッシュの計算境界の中に含まれる

主メッシュのノードとブレークラインを削除して、第二のメッシュに置き換

える。ただし、境界ノードは削除されない。境界ノードも含め、副メッシュ

からの全てのノードが主メッシュに取り込まれる。ただし、境界条件は含ま

れない。副メッシュの時のノードの型（fixed, sliding, floating）は保持される。 

２． Information Transfer： このオプションでは、単に副メッシュから全ての流れ

と河床情報を読み込み、副メッシュの計算境界内の主メッシュのノードにコ

ピーする。 

一般に、副メッシュの計算境界は、主メッシュ内部に含まれるが、そうなること

が必須というわけではない。副メッシュと主メッシュが同じ大きさであっても良

いし、副メッシュが主メッシュを包含することも可能である。 

このコマンドを選ぶと、図 29 で示す Mesh Merge ダイアログボックスが開く。 
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Figure 29: The Mesh Merge Dialog box 

 

オプションを選択し、OK ボタンをクリックすると、副メッシュを定義する.cdg フ

ァイルを指定するための標準のファイルオープンダイアログボックスが現れる。

ファイルを選択し、OK ボタンをクリックすると、副メッシュが主メッシュに結合

される。Region Replace オプションが選択されている場合、主メッシュの変化は

Display メニューから Mesh コマンドを選んでメッシュの要素境界を表示すること

によって簡単に観察できる。メッシュが Information Transfer オプションで結合され

る場合、主メッシュの変化は流れと河床情報だけなので、変化を見つけるはやや

困難になる。 

Mesh Merge コマンドは、Boundary Extraction コマンドとともに使うと便利である。

境界を抽出して作成した部分メッシュを使って定常状態を求めてから、ユーザー

は元のメッシュを主メッシュとし、部分メッシュの結果を副メッシュとして Mesh 

Merge コマンドで結合することができる。 

5.8.4 Mesh Edit->Add Floating Node  

Add Floating Node コマンドによってマウスで浮動ノードを追加するモードになる。

このモードになるとカーソルが十字になる。その後、左マウス・ボタンをクリッ

クした場所に（計算境界内部で）新しい浮動ノードが生成される。浮動ノード追

加モードから抜けるには、もう一度 Add Floating Node コマンドを選択する。また、

Add Floating Node コマンドは、ツールバーのボタンからも利用できる。 

5.8.5 Mesh Edit->Region Refine  

Region Refine コマンドは、ユーザーが指定する多角形領域内部の既存の要素のそ

れぞれに新しいノードを１つずつ追加し、メッシュを精細化する。領域を定義す

るためには、まず最初に、Region Refine コマンドを選択する。これにより、カー



 

 74 

ソルは十字線に変わる。そして、精細化したい範囲を定義するために、メッシュ

境界内で左マウス・ボタンをクリックする。そして、赤い線の左側に精細化した

い範囲が入るように反時計回りに次々と点を打っていく。このようにして、必要

な領域が完全に囲まれるまでクリックしていく。出発点のごく近傍でマウス・ボ

タンをクリックすることによって、多角形を閉じることができる。多角形を閉じ

ると、領域の境界を定義する赤い線は消える。そして、領域に含まれるあらゆる

三角要素の中心に新たなノードが現れる。三角要素化を行うと、その範囲におけ

るノード密度はおよそ２倍（正確には√３倍）になる。図 30 と図 31 は、領域精

細化のプロセスを図示したものである。 

Figure 30: Defining a region to be refined 

-- 
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Figure 31: Nodes that are inserted once the region is defined 

 

5.8.6 Mesh Edit->Auto Refine  

Auto Refine コマンドは Region Refine コマンドと似た動作をする。このコマンドも

既存の三角要素の中央にノードを置くことでメッシュを精細化する。しかし、そ

れは多角形の内側といった空間的基準ではなく、パラメータの値を基準として使

う。Auto Refine コマンドを選ぶと、図 32 に示されるダイアログボックスが開く。 

Figure 32: The Auto Refine Dialog Box 

-- 

このダイアログボックスによって、不等式で精細化のためのパラメータの基準を

設定する。左右の２つの編集ボックスには基準値を入力し、中央の２つのドロッ

プダウンボックスにはこれらの基準値の間に納まるべきパラメータを設定する。

左の編集ボックスには下限値を、右の編集ボックスには上限値を設定する。二つ

目のリストボックスは、基準となるノードパラメータを選択する。選択できるパ

ラメータは、Colour/Contour ダイアログボックスにあるものと同じである。１つ目

のリストボックスは、パラメータの平均値を基準として精細化するか、パラメー
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タの変化量を基準として精細化するかを指定するものである。 

5.8.7 Mesh Edit->Delete Floating Node  

Delete Floating Node コマンドにより、マウスが浮動ノード削除モードに設定される。

削除モードに設定されると、マウスカーソルが十字形に変化する。すべての浮動

ノードは、左マウスボタンでクリックすることにより、赤い X 印が付く。三角要

素を生成するとこれらのノードはメッシュから削除される。Delete Floating Node

は、浮動ノードとスライドノードに対して印をつける。固定ノードや計算境界を

定義するノードは削除できない。また、Delete Floating Node コマンドは、ツールバ

ー・ボタン を選ぶことによっても利用できる。 

5.8.8 Mesh Edit->Clear Untriangulated Nodes  

Clear Untriangulated Nodes コマンドは、まだ三角要素化されていない新たに付加さ

れたノードを削除することができる。こうしたノードには、Add Floating Node コマ

ンドや Region Refine コマンドによって加えられたノードが含まれる。 

5.8.9 Mesh Edit->Triangulate  

Triangulate コマンドはメッシュのすべてのノードを使って三角要素化する。そのコ

マンドは、最も良い三角形を与える constrained(束縛) Delauney 三角要素化ルーチン

を呼び出す。すなわち、そのルーチンは、できるかぎり正三角形に近い三角形を

生成しようとする。束縛は、三角形が定義領域境界を越えないことを保証するた

めに必要である。Triangulate コマンドは、また、ツールバー・ボタン を選ぶこ

とによって利用できる。注：このコマンドは、ノードが挿入されるか、削除マー

クが付加された時のみ有効になる。 

5.8.10 Mesh Edit->Smooth  

Smooth コマンドは三角形をより正三角形に近づけ、異なるサイズの三角形の間の

移行をよりスムーズにし、元の地形をよりよく表現できるようにする。スムージ

ングプロセスは、それぞれのノードを隣り合うノードのより中央、また、地形勾

配の変曲点の方向に移動させる。点が移動された後、再度三角要素化が実行され

る。スムージングプロセスは、必要なだけ繰り返して実行する。これにより、メ

ッシュはよりなめらかでより規則的になる、しかし、元々設定してあった重要部

分とそうでない部分のメッシュ密度の差は徐々に減少する。 

Smooth コマンドは、実際には要素の形を地形の再現性を基準に浮動ノードとスラ

イディングノードを移動させている。ノードは、河床とメッシュの高さの食い違
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いが最も大きい近接する三角形に向かって移動する傾向がある。高さの違いは、

要素のセンターで計られる。地形的な基準の相対的重要性を制御するパラメータ

（Bias Smoothing Parameter と呼ばれている）は Options メニューに含まれる Mesh 

Edit Options ダイアログで設定できる。ゼロにすると、地形基準を考慮しなくなる。

１にすると、要素形状を考慮しなくなる。このパラメータを大きな値にするほど、

近接する要素との大きさ違いが許容されるようになる。 

Smooth コマンドはまた、ツールバー・ボタン からも利用できる。 

5.8.11 Mesh Edit->Mesh Information…  

Mesh Information コマンドを選択すると、ノードの総数、三角要素の総数とメッシ

ュの品質指標（QI 値）が表示されたウインドウが現れる。これを図 33 に示す。

QI は、生成された全ての三角要素のうち最小の三角形の品質値である。三角形の

品質値は、三角形の３頂点を通る円の面積に対する三角形の面積の比率を、正三

角形に対するそれで正規化したものである。したがって、理想的なメッシュ（正

三角形）は、1.0 の QI を持つ。実際のメッシュは、1 未満の QI を持つ。典型的な

許容できる値は、0.1 から 0.5 程度であろう。QI が非常に低いとき、スムージング

は劇的に QI を増やす。多くのブレークラインを持つメッシュ、特に狭い間隔でブ

レークラインが配置されている場合には、QI 値は低くなる。 

Figure 33: The Mesh Information box 

 

5.9 生息場分析 

許容できる流体力学解が得られれば、Habitat メニュー下の生息場分析操作を用い

て生息場分析が実行できる。Habitat メニューを図 34 に示す。利用できる操作は、

以下のとおりである。 

生息場解析を行う前に、.cdg ファイルをロードしておかなければならないことに注
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意のこと。 

Figure 34: The Habitat Menu 

  

5.9.1 Habitat -> Preference  

Preference コマンドは、選好曲線ファイルをロードするために使用する。.prf.の拡

張子に対するフィルタ設定がされた標準 Open File ダイアログが開く。ファイルを

選択し、ロードすると、Habitat メニューの Preference コマンドの前にチェックマー

クが現れる。 

各.prf ファイルは、一つの種／成長段階に対する水深・流速・河道指標についての

選好曲線を含んでいる。各選好曲線は括弧で区切られる。そして、曲線上の点は

１点１行で、点番号、パラメータ値、対応する選好値をスペースで区切って入力

する。表２は、Juvenile Brown Trout についての.prf ファイルの例である。 

複数の種／成長段階について分析する必要があるなら、選好曲線ファイルを続け

てロードし、WUA をそれぞれに対して計算すればよい。 
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Table 2: A sample .prf file 

 

5.9.2 Habitat -> Channel Index  

Channel Index コマンドは河道指標ファイルをロードするために使用される。.chi

拡張子に対するフィルタつきの標準 Open File ダイアログが開く。ファイルを選び、

ロードすると、チェックマークが Habitat メニューの Channel Index コマンドの前

に現れる。 

河道指標ファイルは、粗度高さが河道指標に置き換わっている以外は、.bed ファイ

ル同じフォーマットを持つ。新しい河道指標ファイルをロードすると、それまで

メモリ上にあった値は新しいファイルの値に置き換わる。表 3 は、サンプル.chi フ

ァイルの数行を示している。 
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Table 3: A section from a sample .chi file 

 

5.9.3 Habitat -> Weighted Usable Area  

Weighted Usable Area コマンドは、現在の流体力学解、選好曲線ファイル、河道指

標ファイルに基づいて重み付き利用可能面積を計算する。WUA を求めた結果は、

図 35 に示すように、全面積とともに情報ボックスに表示される。一旦 WUA 計算

が実行されれば、いろいろな生息場インデックスの表示が可能となる。 

Figure 35: The Weighted Usable Area information box 

 

5.9.4 Habitat -> Save Node Attribute File  

Save Node Attribute File コマンドは、それぞれのノードの流体力学情報に加えて、

生息場情報をも保存する出力オプションである。全ての生息場指標が各ノードで

定義されるから、WUA 計算が最初に実行されなければならない点に注意しなけれ

ばならない。 

Node Attribute ファイルのフォーマットは、２行の情報行と、引き続くノードあた

り１行のデータである。最初の情報行は、最も新しく WUA を計算するために使わ

れたメッシュ・ファイル(.cdg)、河道指標ファイル（.chi）、選好曲線ファイル (.prf)
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の名前を含む。二行目の情報行は、ノード属性のための絡む見出しである。以下

の各行は、ノード番号、x 座標、y 座標、水深、流速、河道指標、水深の適性値、

流速の適性値、河道指標の適性値、合成適性値、およびそのノードについての WUA

である。区切り文字はコンマが使われる。 

5.9.5 Habitat -> Save Physical Attributes  

Save Physical Attributes は各ノードの流体力学情報を保存するコマンドである。

WUA 計算は、実行されている必要はない。河道指標ファイルは、設定されていて

もいなくてもよい。 

Node Attribute ファイルは、３つの情報行と、１ノード１行のデータ行からなる。

最初の情報行は、メッシュ・ファイル(.cdg)と河道指標ファイル（.chi）の名前が含

まれている。第二行は、現在の総流入量とノードの総数を含む。第三行は、ノー

ド属性のためにコラム見出しを含む。以下の各行はノード番号、x 座標、y 座標、

水深、流速、河道指標、そのノードに従属する面積を含む。区切り文字はコンマ

である。 

5.10 結氷の操作  

River2D は、結氷の下の流れをシミュレーションする能力を持つ。Ice Cover メニ

ューは、ユーザーに 2 つのコマンドを提供する。一つは計算結果の領域の中に氷

を組み込むこと、もう一つは不要になった氷を取り除くことである。これらのコ

マンドについて、以下で詳述する。 

5.10.1 Ice Cover-> Load Ice File  

結氷の下の流れをシミュレーションする前に、結氷地形を計算領域全体に渡って

定義しておかなければならない。すなわち、氷厚と氷粗度を、全ての計算ノード

に対して指定しなければならない。これらの値は、別の氷地形ファイルから内挿

する。河床高と河床粗度が氷厚と氷粗度に置き換わっていること以外は、氷地形

ファイルは河床地形ファイルと同じフォーマットである。氷地形ファイルの構造

については、R2D_Ice ユーザー・マニュアルを参照してほしい。 

Load Ice File コマンドを選ぶと、.ice 拡張子フィルタが設定された標準の Open File

ダイアログボックスが開く。ファイルを選び、OK ボタンをクリックすると、氷地

形は以下のように計算ノードに割り当てられる。 

1. TIN が氷ファイルのノードから生成される。 

2. 計算メッシュの各ノード位置がチェックされる。それが氷 TIN で空間的に氷
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で覆われた要素内に入るならば、ノードの氷パラメータ（氷厚と氷粗度）は

要素から線形補間される。それが凍っていない要素に入るならば、ノードの

氷パラメータは 0 に設定される。氷で覆われた要素と凍っていない要素は氷

厚のノード値によって見分ける。要素の中のノードのいずれかが 0 の氷厚さ

を持つならば、要素全体に氷はない。そうでなければ、氷で覆われた状態で

あるとする。 

氷パラメータが割り当てられると、領域の氷厚値が図 36 で示す色分け図を使って

自動的に表示される。氷に覆われた要素（全てのノードに０より大きな氷厚値を

持つ）はノードの氷厚に応じて薄青の濃淡がついている部分である。領域の中の

開水域はダークブルーの色がついている。 

Figure 36: A sample cdg file with ice thickness displayed 

 

新しい氷ファイルがロードされると、既存の氷 TIN は新しい氷ファイルのノード

に基づくものに置き換わる。そして、ノードの氷パラメータは、新しい氷 TIN を

反映するよう更新される。 

5.10.2 Ice Cover -> Remove Ice  

名前からわかるように、この命令はモデルから氷を削除する。氷 TIN は削除され、

ノードの氷厚と氷粗度は 0 にリセットされる。 

5.11 オプション設定操作 

River2D 環境でユーザーが設定できるパラメータは数多くある。これらは、流況計

算に関するもの、メッシュ編集コマンドに関するもの、生息場分析計算に関する

ものなどを含む。これらのオプション設定操作について以下で説明する。 
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5.11.1 Options -> Habitat Options  

図 37 で示される Habitat Options ダイアログボックスは生息場分析のため河道指標

（Channel Index）内挿法と、WUA 計算法オプションとがある。 

Figure 37: The Habitat Option dialog box 

 

河道指標値は、メッシュの全ての計算ノードについて評価される必要がある。し

かし、それら.chi ファイルにおいて別の点の集合として指定されている。河道指標

が指定されている点から計算ノードへの展開法は、連続データとして扱う場合と

離散データとして扱う場合がある。「連続」という意味は、河道指標がある範囲に

わたって連続的に変化するような値をとる、ということである。カバー率はその

一例である。Continuous オプションが選択されると、モデルにおいて任意の点にお

ける河道指標値は、その点を囲むノード値の線形補間によって評価される。他方

で、離散的な河道指標は、特定のクラスやカテゴリーを表すものである。Discrite(離

散的)オプションを選ぶと、任意の点における河道指標はその点に最も近いノード

の河道指数と等しいとみなされる。 

WUA Calculation Method は、水深、流速、河道指標についての 3 つの個別の適性指

数から、合成適性値を計算する手続きについて言及する。Product は３つの指標を

掛け合わせる。Geometric mean は掛け合わせた値の立方根をとる。Minimum は、

３つのうち最小の値である。 

5.11.2 Options->Mesh Edit Options  

Mesh Edit Optionsコマンドは2つのパラメータを設定するためのダイアログボック

スを開く。まず、Bias Smoothing Parameter は 0（地形の効果なし）から 1（要素形

の効果なし）の間の値に設定されなければならない。デフォルト値は 0.5 である。
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二番目の Bed Contour Interval は、河床地形等高線図の等高線間隔である。このデ

フォルト値も 0.5 である。Mesh Edit Options ダイアログボックスは、図 38 で示さ

れる。 

Figure 38:Mesh Edit Options dialog box. 

 

5.11.3 Options->Flow Options  

Flow Options コマンドは図 39 で示すダイアログを開く。このダイアログでは、水

理計算解に影響を及ぼすいろいろなパラメータが設定できる。これらのパラメー

タは、.cdg 入力ファイルの冒頭に記述されているものである。従って、このダイア

ログで変更する以外にも、.cdg ファイルを手で編集することで変更することもでき

る。.cdg ファイルが R2D_Mesh で最初に作成されるとき、これらのパラメータの

ためのデフォルト値が設定される。 

最初の upwinding coefficient は、流体力学方程式を解くために使われる

Petrov-Galerkin 有限要素法のパラメータである。upwinding coefficient（ω）は、0

から 1 の間の値をとる。Hicks と Steffler (1992)は、非定常問題に対してω= 0.25、

定常問題に対してω= 0.5 を推奨している。デフォルトはこの値になっている。 

非常に浅い流れや干出した要素に関連した計算の困難を避けるために、問題地域

では基礎式が表面流の式から地下水流の式に切り替わる。第 2、第 3、第 4 のパラ

メータは、地下水流がモデルで取り扱われる方法と関連する。 

第 2 のパラメータは、地下水流の式に切り替わる最小水深である。デフォルト値

は 0.01 になっている。 

第 3 のパラメータ式 13 に現れるは地下水透過率である。transmissivity にはどんな

正の値を入力してもよいが、地下水流量が表面流と比較して無視できることを確

実にするためには小さい値を使うことが勧められる。デフォルトでは 0.1 である。

広い干出区域における水面高の調整スピードを一時的に高めるために、大きな値
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を設定する場合がある。 

第 4 のパラメータは式 13 の地下水 storativity である。storativity は、単位面積あた

り単位地下水面低下で放出される水量として定義される。不圧地下水がモデルで

仮定されるので、strativity は 0（地面の多孔性なし）から 1.0（表流水と同じ）ま

で変動することができる。デフォルト値は 1.0 になっている。storativity を下げる

ことは、地下水面高をより速く正味地下水流の変化に反応させることになる。 

最後の 3 つのパラメータは式 11、12 の渦粘性係数（νt）を定義するために使われ

る。.cdg ファイルでは、ε1、ε2 とε3 は、渦粘性定数、渦粘性河床せん断パラメ

ータ、渦粘性水平せん断パラメータと名づけられている。（古い.cdg ファイルでは

それぞれ Mimimum Depth for Diffusive Wave Calculation、DIF、Groundwater Flow 

Artificial Diffusion となっているかもしれない。） 

ε1 のデフォルト値は、0（旧バージョンの River2D では 0.01）である。この係数

は、式 12 の第二項がνt の記述のために適切でなくなるような非常に浅い流れで

の解を安定させるためのものである。この係数の妥当な値は、モデル化されたサ

イトの平均水深と平均流速を使って式 12 の第二項を評価することによって計算す

ることができる。 

ε2 のデフォルト値は 0.5 である。河川での横分散係数とのアナロジーにより、0.2

～1.0 が妥当であろう。大部分の河川の乱流が河床せん断で発生するので、この項

は通常最も重要なものである。 

深い流れや横方向の流速が高いような流れでは、横せん断が主要な乱流発生機構

となる。強い短絡流が発生しているような部分がその重要な例である。これらの

ケースでは、式 12 の中の第 3 項（ε3）が重要になる。それは、本質的に 2D（横）

混合距離モデルである。混合距離は、水深と比例すると仮定される。ε3 の典型的

な値は 0.1 である、しかし、これはキャリブレーションで調節されるかもしれない。

デフォルト値は 0（River2D の旧バージョンでは 0.1）である。 
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Figure 39: The Flow Options dialog box 

 

5.11.4 Options->Solver Options  

Solver Optionsコマンドは図 40に示されるダイアログを開く。このダイアログでは、

ユーザーが線形解法を選択することができる。ユーザーは、直接解法である active 

zone equation solver (Stasa 1985)か、反復解法である GMRES(m) method (Saad and 

Schultz 1986)を選択することができる。直接解法は、少ないノード数（<10K ノー

ド）では速いが、大きいメモリを必要とする。GMRES 解法は、メッシュが多い時

にはより速く、記憶域も小さい。GMRES 解法は、比較的短い時間ステップ長に限

られる。 

反復解法は、3 つのユーザー定義可能なパラメータを持つ。第一はアルゴリズムが

再開される前のステップ数、第二は最大繰り返し数（許容再開数）、第三は、ゴー

ル収束許容値である。これらの値は、それぞれ 10、10、0.01 に設定されている。

これらの値は、反復解法の解が直接解法の解と似た値になるかどうかについて試

行錯誤により確認しながら定めたもので、十分にテストされたものではない。こ

れらのパラメータに対する最適の値は、扱う問題によって異なるものと考えなけ

ればならない。将来的には、より大規模なテストを行い、これらのパラメータ値

の選定方法に対するガイドラインが利用できるようになるだろう。 
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このダイアログでは、ユーザーがヤコビ行列を評価する方法をAnalytical(解析法)、

Numerical(数値法)から選択することもできる。解析法は速く、数値法はより正確で

ある。デフォルトで解析法が選択されている。ヤコビ行列の評価法選択に関する

アドバイスは、次の通りである。定常解析では、まず解析法を使用するのがよい。

解の変化が 0.001 のオーダーの比較的小さな値に達した後、収束状況が向上しない

ようなら、数値法に変更する。非定常解析には解析法が適切である。 

Figure 40:The Solver Options dialog box. 

 

5.11.5 Options -> Transient Output Options  

このコマンドは図 41 で示す Transient Output Options ダイアログを開く。このダイ

アログでは、モデルが非定常モードで実行しているときの出力形式を指定できる。

このダイアログボックスは、また、Run Transient ダイアログの Output Options ボタ

ンをクリックすることでもアクセスできる。ここでは、Video output, Point output, 

cdg output の３種類の出力形式に対する設定ができる。 
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Figure 41: The Transient Output Options Dialog 

-- 

このダイアログボックスの上部のセクションは、計算結果を AVI ファイルとして

ビデオ出力するためのものである。結果として生じるビデオ・アニメーションは、

ディスプレイ・ウインドウから直接キャプチャされた連続したフレーム画像を集

積したものである。したがって、非定常シミュレーション中にディスプレイ・ウ

インドウに表示されている外観（ズーム率、ディスプレイ・パラメータ、注釈、

その他）がそのままビデオにも表示される。Output frame every □ goal time steps

オプションは、画面キャプチャの頻度を指定するものである。例えば、goal time step

が 5 で、Run Transient ダイアログでの現在時間が 0 と指定されていれば、出力され

るフレームは t=0, 5, 10, 15・・・となる。また、再生速度とビデオ解像度を指定す

ることができる。 
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ダイアログボックスの中間のセクションは、計算領域内の指定点で非定常計算デ

ータを出力するものである。この出力は、csv（Comma Separated Values;コンマで区

切った値）ファイル形式である。出力する点は、断面上でも、格子点上でも、あ

るいは散在した点でも良いが、別々の csv ファイルで指定する。Display メニュー

における csv ファイル出力コマンドは、必要な出力点を得る効果的な方法を提供す

る。入力 csv ファイルのサンプルを図 42 に示す。 

Figure 42: A sample input point csv file 

 

 

出力する変数については、水深、水面高、x 方向流量、ｙ方向流量の 4 つの選択肢

がある。これらを選択すると、それぞれ別々の csv ファイルが出力される。これら

のファイルには、変数の略語にユーザが指定する接頭語を付加した名前がつけら

れる。例えば、Fortress を接頭語とすれば、生成されるファイルは Fortress_h.csv、

Fortress_wse.csv、Fortress_qx.csv と Fortress_qy.csv といったものになる。ファイル

接頭語に加えて、ユーザーはまた、ファイルの出力フォルダと出力頻度を指定し

なければならない。出力された csv ファイルのフォーマットは、図 43 で示される。 
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Figure 43: A sample output point csv file shown in MS Excel 

 

ファイルの最初の４行は、この計算の元になった.cdg ファイルのパス、出力された

パラメータ名(この例では水面高)、この csv ファイル生成された日付、この csv フ

ァイルが初期化された時刻である。第 5、第 6 行は、それぞれ指定された点の x 座

標、y 座標である。以降の行は、指定されたポイントの出力パラメータの値で、第

一列はモデル時間である。例えば t=30s における点(4998, 5066)での水面高は、

199.219 である。 

ダイアログボックスの一番下のセクションは、.cdg ファイル形式での非定常データ

の出力に関する設定である。この機能によって、必要な場合、非定常解析結果を

次の River2D による計算の入力ファイルとすることができる。ビデオ出力や点出力

での利用も考え、.cdg 出力についても goal time step の頻度として指定することが

できる。生成される cdg ファイルは、ユーザーが定義する接頭辞と現在のモデル時

間（例えば Fortress500.cdg）という名前をつけて、ユーザーが指定したフォルダに

出力される。 

必要な設定を行い、Initialize Output ボタンを押すことで、出力ファイルの初期化が

行われる。Initialize Output ボタンを押した後は、Close ボタンでダイアログを閉じ

てよい。Initialize Output ボタンを押さずに close ボタンをクリックすると、設定し

た事項は無視されてしまう。 

5.11.6 Options->Ice Options 

このコマンドは、図 44 で示す Ice Options ダイアログボックスを開く。 
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Figure 44: The Ice Options Dialog Box 

 

現在のところ、このダイアログでは、氷の比重だけが設定できる。氷ファイル・

エディタ R2D_Ice を使用して ice ファイルを保存すると、ファイルの最後に比重値

が記述されており、このダイアログボックスに現れる比重値はそこから取られる。

しかし、River2D は、テキスト・エディタで作成された、このパラメータ値が記述

されていない ice ファイルも入力することができる。現在使用している ice ファイ

ルが氷の比重値を含んでいない場合、このボックスに現れる値はデフォルト値 0.92

である。この値を変更すると、River2D を閉じるまでは以降の計算においてその値

が使用される。ただし、その値は.ice ファイルにも.cdg ファイルにも保存されない

ことに注意する必要がある。 
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