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Introduction 
 
 
This manual is to describe the work with NaysEddy by giving two examples, and explains how the user can 
solve the flow accurately using iRIC. You can understand how to apply NaysEddy sufficiently if you follow the 
procedures shown in this manual step by step. The user manual of iRIC and the solver manual for NaysEddy 
will help you to obtain a better understandings on the contents of this present examples manual. 
 
NaysEddy is compiled under iRIC interface. Therefore, to use NaysEddy, basic knowledge about iRIC is 
necessary.  This manual is based on the assumption that you have installed the iRIC software on your computer. 
If you have not installed the iRIC software, please download it from the following URL and install it on your 
computer. 
 
http://i-ric.org/downloads 
Software: iRIC version2.0 
 
Main contents of this manual are, 
Chapter 2. Example of three-dimensional flow computations on cosine-form dunes utilizing NaysEddy Chapter 
3. Example of computations on a three-dimensional arbitrary bed topography using NaysEddy 
 

Note：The main purpose of this manual is just to show the practical and concrete examples of computational 
procedure using NaysEddy. Some detailed physical explanations are thus omitted for simplicity, such as, model 
descriptions and the physical background of the each phenomenon, etc. The adequate setting of the 
computational grid is also very important to replicate detailed three-dimensional flow structures. 
 
The following figure shows the steps necessary in simulation of flow using NaysLES. 
  

 

Generating the computational grid: Generate the computational grid by using 

the related grid generator for NaysEddy 

Running a simulation: Use NaysEddy to run a simulation. 

Visualizing the simulated results: Visualize the simulated results by contour 

maps, vectors, streamlines, particles. 

Setting the computational conditions: Set initial and boundary conditions, etc. 

Launch NaysEddy: Prepare to use NaysEddy in iRIC 



Getting started 
 
 
The starting step of the simulation in iRIC is the selection of a suitable solver. In order to select the desired 
solver, you need prior information about the functions of each solver. It can be obtained from iRIC user manual.  
 
Here, we explain an application to NaysEddy. This solver can be run by opening iRIC, and selecting [Create New 
Project] from “iRIC Start Page”.   
 

Dialog of “iRIC Start Page” → [Create New Project] → [NaysEddy v.1.0 xxx] 
 

 

 

 
 
It is also possible to select your solver via menu bar. 
 

Select Menu bar → [New Project] → [NaysEddy v.1.0 xxx] 
 

 

 

 
 
A dialog will appear. 



Select NaysEddy v.1.0 xxx → [OK] 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Simulation of flow over dunes 
 
 

1. Purpose of this example 
 
This is an example for applying NaysEddy in iRIC to calculate the flow on a bed, covered with dunes, using 
large-eddy simulation. Reading this section enables you to understand the basic operations of NaysEddy in 
simulating the flow. 
 
 

2. Generate a computational grid 
 
Generate a computational grid with a rectangular cross section to be applied for NaysEddy solver. The grid for 
NaysEddy is different than the common grids used in iRIC interface. For NaysEddy, you need to choose the 
related option carefully. A wrong selection may lead to unpredictable computational errors or instabilities. In 
order to generate a grid for NaysEddy, you can follow the next steps: 
Select Menu bar → [Grid] → [Select Algorithm to Create Grid]. 
Then from the dialog, 
 

[Select grid creating algorithm] → [Cartesian Grid for NaysEddy xxx] 
 

 

 

 
 
Press on OK. The grid dialog appears. In this example, we solve the flow on cosine form crested bed. The stoss 
side of the dunes are cosine form and they are followed by lee side with a defined angle.  
 
 
 
 
 
 
 



  

 

Bed topography → [2D-Dune 
cosine] 
 
Bedform length [m] → 1 
 
Bedform width [m] → 0.5 
 
Bedform height [m] → 0.1 
 
Angle pf lee-side [deg] → 30 
 
Number of bedforms → 2 
 
Minimum x [m] → 0 
 
Minimum y [m] → 0 
 
Zero level [m] → 0 
 
nx (imax=2^nx) → 8 
 
ny (jmax=2^ny) → 6 

 
 
Click on [Create Grid]. You will be asked either you want to map geographic data to the grid attributes. Click 
on [Yes]. The computational grid will be generated as follows; 
 

  

 

 

 
 
In order to see the counter map of the elevation, check in [Node attributes] and [Elevation] in the “Object 
browser”.  
 
 
 
 



 

 

 

 
 
The bed topography can be also seen in a 3D view. In order to see the bed topography in 3D, select  
 

Start menu → [Grid] → [Open Bird’s-Eye View Window] 
 

 

 

 
 
However, the ratio of bed height to bed with is automatically adjusted. You can change the aspect ratio by 
 

Select start Menu → [Draw] → [Z-direction Scale]  
And change the “Input new Z-direction scale” to 1. 
 

 

 

 
You can rotate the geometry by keeping [Ctrl] key and the right mouse bottom. 
 

3. Solve the flow 
 
As the grid is now ready, you can start the solution of the flow. The first step in the solution of the flow is 
setting the conditions. The conditions can be set by  



Start Menu → [Calculation Condition] → [Setting] 
The “Calculation Condition” dialog appear as it is shown in the following Figure. 
 
3.1. Grid 
 
Although, the flow model is three-dimensional, while the generated grid is two-dimensional. In order to 
change the grid to a three-dimensional form, we add horizontal layers. They are parallel layers starting from a 
minimum z-level.  The value for [Minimum z] has to be smaller than the minimum z-value of the bed geometry. 
As in the grid generation, we have chosen a zero level of 0, with bed height of 0.1, it makes a minimum value 
of -0.05 for the bed. 
 

 

 

Minimum z [m] → -0.06 
 
Maximum z [m] → 0.2 
 
nz (kmax=2^nz) → 6 

 
 
3.2. Flow conditions 
 
In this part, you need to enter the physical properties related to the water.  
 

 

 

Kinematic viscosity [m2/s] →  
1e-6 
 
Density [kg/m3] → 1000 
 
Gravity [m/s2] → 9.81 
 
Discharge [m3/s] → 0.1 

 



3.3. Time conditions 
 
This part sets the starting time and ending time and it determines the time step. 
 

 

 

Start time [s] → 0 
 
End time [s] → 1000 
 
Time step type → [Automatic] 
 
CFL number → 0.35 

 
 
3.4. Initial and boundary conditions 

 
The boundary conditions as well as the initial conditions can be set by this option. 
 

 

 

B.C. x-direction → [Periodic] 
 
B.C. y-direction → [Side wall] 
 
B.C. z-direction → [Free surface] 
 
Initial conditions → [Uniform 
discharge based] 
 
Include initial perturbations → 
[Yes] 
 
Perturbations amplitude → 0.001 

 
 
3.5. Bed conditions 
 
The bed topography, which was generated by the grid generator, can be modified by adding roughness and 
perturbations to mimic a realistic river bed.  
 
 
 
 



 

 

Bed type → [Sediment bed] 
 
Sediment size [mm] → 1 
 
Add bed perturbations → [Yes] 
 
Amplitude [mm] → 0.001 

 
 
3.6. Solution conditions 
 
The solution conditions, such as the constant for turbulence model, the interpolation method for the 
immersed boundaries, and coefficients for the multigrid solver, can be set here. 
 

 

 

Smagorinsky constant → 0.16 
 
IBM interpolation → [Tri-linear] 
 
Multigrid type → [W-Cycle] 
 
Cycle index → 2 
 
Pre-smoothing → 1 
 
Post-smoothing → 1 
 
Maximum cycles per time  
iteration → 50 
 
Stop criterion → 1e-8 

 
 
3.7. Hot Start conditions  
 
In the case, you need to start the simulation from a prior generated hotstart file, this option can help you to 
read the related file. 
 
 
 
 
 
 



 

 

Hot start → [No] 

 
 
3.8. Output 
 

 

 

Time interval for iRIC output [s] 
→ 10 
 
Output for hot start [s] → [Yes] 
 
Time interval for hot start [s] → 
10 
 
Tecplot output → [No] 
 
Output folder → c:\temp 
 
Output file name → output 

 
 

4. Run the simulation 
 
Now, you are in the state, able to run this simulation. To run the simulation choose, 
 

Start menu → [Simulation] → [Run] 
 

 

 



Before the simulation starts, iRIC interface ask you either you need to save the project. Click on [Yes] and select 
[Save as Project]. Make a new directory and save the project in that directory. Be aware that NaysLES requires 
relatively large space on the harddisk. 
 

  

 

 

 
 
When the simulation starts, a new dialog appear as it is shown in the following figure. 
 

  

 

 

 
 

5. Visualize the results 
 
After simulation, you may need to visualize the results. iRIC uses a built-in post-processor which enables the 
iRIC users to visualize the results without using a third party software.  
 

Select [calculation result] → [Open new 3D post-processing window] in menu bar, or click on the button 
shown in the following figure 
 

 

 

 



A 3D post-processing window will open. You can slide or rotate the object by keeping [Ctrl] key and using they 
mouse bottoms.  
 

 

 

 

 
 
In the left side, namely in the “object browser”, options as “Contour”, “Isosurface”, “Arrow”, “Streamlines” 
and “Particles” are available. They are different modules for visualizing the results.  
 
 For example, the velocity field can be easily understood by plotting the colors contours of the velocity. 
  

Right click on [Contour] → [Properties] 
 

 

 

Physical Value → [Velocity 
(magnitude)] 
 
Click on [Add] 
 
Direction → J 
 
Range → 
   I Min → 1 
   I Max → 257 
   J Min → 32 
   K Min → 1 
   K Max → 65 
 

 
After clicking on [OK], the velocity contour appears as the following figure.  
 
 
 
 
 
 
 
 



` 

 

 
  

 
 
The isosurface is suitable to visualizing the flow structures.  
 

Right click on [Isosurface] → [Properties] 
 

 

Physical Value →  [Coherent] 
 
Iso Value → 250 

 
After clicking on [OK], the isosurface of the turbulence coherent structures appears as the following figure. 

 

 

 

 



Right click on [Arrow] → [Properties] 
 

 

Uncheck [Auto] 
 
Standard value → 1 
 
Length on screen → 30 
 
Minimum value to draw → 0.01 
 
Sampling rate → 7 
 
Click on [Add] 
 
Direction → J 
 
Range  
   I Min → 1 
   I Max → 257 
   J Min → 32 
   K Min → 1 
   K Max → 65 

 
 
After clicking on [OK], the velocity vectors appear as the following figure. Here, the velocity vectors are drawn 
together with the velocity contours to make the visualization more clear. 
 

  

 

 

  
 
You can also visualize the streamlines.  
 
 
 
 
 
 
 



Right click on [Streamlines] → [Properties] 
 

 

Range 
   I Min → 1 
   I Max → 1 
   J Min → 1 
   J Max → 65 
   K Min → 1 
   K Max → 32 
 
Generation space interval → 1/5 

 
 
After clicking on [OK], the streamlines appear as the following figure. 
 

  

 

 

 
 
It is also possible to visualize the one-dimensional profiles (in intersections). For doing this, you need to open 
a new window by clicking on the diagram icon on the toolbar (the following figure). 
 

Select on toolbar [Diagram icon] → [Click] 

 

 

 
 
After clicking this icon, a dialog window will be open. In this dialog, you can define the desired variable and 
the intersection. For example, for the velocity, you can do as following figure  
 



  

 

X Axis → K 
 
Select [Velocity (magnitude)] 
from left panel and transfer it to 
the right panel by [Add >>] 
 
Click on [Setting]  
   Width → 4 

  
 

 
 
After clicking [OK], a new window appears in which x-axis is the disdance in K-direction and y-axis is the 
magnitude of the velocity. I and J coordinated can be determined by the slide bars under the diagram.  
 

  

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 



Simulation of flow over arbitrary topography 
 
 

1. Purpose of this example 
 
The purpose of this example to practice the way in which you can import a bed topography which is not 
included in the library of the solver. Such geometry need to be imported from an external data file.  
 

2. Generate a computational grid 
 
Similar to the first example, you need to start NaysEddy. Because of the similarity to the first example, 
explanation about starting NaysEddy is omitted in this section. After opening NaysEddy, you need to generate 
a grid. Similar to last example, the grid generation process can be obtained by 
  
Select Menu bar → [Grid] → [Select Algorithm to Create Grid]. 
 
Then from the dialog, 
 

[Select grid creating algorithm] → [Cartesian Grid for NaysEddy xxx] 
 

 

 

 
 
Note that selection of a false grid can lead to instability or immediate determination of solver. After the grid 
is selected, the “Grid Creation” dialog will be open as shown in the following figure. Here, we import the bed 
topography from an external file. This file is independent of iRIC and has to be generated manually, or by third 
party applications. For example, you can use Fortran or C to generate your desired topography. This 
topography can be the results of calculations or can be imported from experimental data. Here, we included 
a file for this purpose. This file was generated by calculating the morphodynamical change into a flume 
experiment. This file can be found attached in the directory. 
 
 



  

 

Bed topography → [Custom] 
 
Bed topography file → Read from 
harddisk (bedform-ex02.dat) 
 
nx (imax=2^nx) → 8 
 
ny (jmax=2^ny) → 7 

 
 
Click on [Create Grid]. You will be asked either you want to map geographic data to the grid attributes. Click 
on [Yes]. The computational grid will be generated as follows.  
 

[Object Browser] → [Node attributes] → [Elevation]    
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Using bird’s-eye option, you can see the bed topography three-dimensionally. Similar to the former example, 
the bird’s-eye view can be found under [Grid] in [Menu bar] 
 
 
 
 
 
 
 
 
 



Start menu → [Grid] → [Open Bird’s-Eye View Window] 
 

 

 

 
 

Start menu → [Grid] → [Open Bird’s-Eye View Window] → Mouse Buttons 
 

 

You can move or rotate the 
topography by keeping [Ctrl] key 
and using the mouse buttons.  
 

 

 
 

3. Solve the flow 
 
After grid is generated successfully, you can start to solve the flow on the current grid. The flow conditions can 
be set, similar to the former example, by selecting [Calculation Condition] from the menu bar.  
 
Select Menu bar → [Calculation Condition] → [Setting] 
 
The dialog window for “Calculation Condition” appear as it is shown in the following figures. In the left panel 
of this dialog (Groups panel), you need to set the flow conditions. 
 
 
3.1. Grid 

 
The first step is initiating the grid in the vertical direction in order to convert it to a three-dimensional grid. 
The minimum value has to be smaller than the minimum value of the topography, otherwise the solver gives 
an error message, and requires you to adjust this value. 
 



  

 

Minimum z [m] → -0.04 
 
Maximum z [m] → 0.045 
 
nz (kmax=2^nz) → 6 

 
 
3.2. Flow conditions 
 
You can set the physical properties of the flow. 
 

  

 

Kinematic viscosity [m2/s] →  
1e-6 
 
Density [kg/m3] → 1000 
 
Gravity [m/s2] → 9.81 
 
Discharge [m3/s] → 0.0068 

 
 
3.3. Time conditions 
 
The starting time, calculation time and the time step can be set here. Choosing Automatic time step allows 
the solver to calculate the suitable time step based of the CFL number. It leads to a safely calculated time step. 
If you set the time step manually, there is a risk that the time step exceeds the allowed time step locally or 
globally, which leads to instability. Hence we here prefer to use automatic calculation of the time step to avoid 
possible instabilities. Selecting smaller CFL number (< 0.35) does not decrease the instability, but increases the 
computational time. Large values of CFL number (>0.35) may lead to an instable solution.  
 
 



  

 

Start time [s] → 0 
 
End time [s] → 300 
 
Time step type → [Automatic] 
 
CFL number → 0.35 

 
3.4. Initial and boundary conditions 
 

  

 

B.C. x-direction → [Periodic] 
 
B.C. y-direction → [Side wall] 
 
B.C. z-direction → [Free surface] 
 
Initial conditions → [Uniform 
discharge based] 
 
Include initial perturbations → 
[Yes] 
 
Perturbations amplitude → 0.001 

 
3.5. Bed conditions 

  

 

Bed type → [Sediment bed] 
 
Sediment size [mm] → 0.25 
 
Add bed perturbations → [No] 
 



3.6. Solution conditions 
  

 

Smagorinsky constant → 0.16 
 
IBM interpolation → [Tri-linear] 
 
Multigrid type → [W-Cycle] 
 
Cycle index → 2 
 
Pre-smoothing → 1 
 
Post-smoothing → 1 
 
Maximum cycles per time → 50 
Stop criterion → 1e-8 

 
3.7. Hot Start conditions 

  

 

Hot start → [No] 

 
3.8. Output 

  

 

Time interval for iRIC output [s] 
→ 5 
 
Output for hot start [s] → [Yes] 
 
Time interval for hot start [s] → 
10 
 
Tecplot output → [Yes] 
 
Output folder → c:\temp 
 
Output file name → output 



4. Run the simulation 
 
Now, you are in the state, able to run this simulation. To run the simulation choose, 
 
Start menu → [Simulation] → [Run] 
 
Before the simulation starts, iRIC interface ask you either you need to save the project. Click on [Yes] and select 
[Save as Project]. Make a new directory and save the project in that directory.  
 
 

5. Visualize the results 
 
After simulation, you may need to visualize the results. iRIC uses a built-in post-processor which enables the 
iRIC users to visualize the results without using a third party software.  
 

Select [calculation result] → [Open new 3D post-processing window] in menu bar, or click on the button 
shown in the following figure 
 

 

 

 
A 3D post-processing window will open. You can slide or rotate the object by keeping [Ctrl] key and using they 
mouse bottoms.  
 

 

 

 

 
 
In the left side, namely in the “object browser”, options as “Contour”, “Isosurface”, “Arrow”, “Streamlines” 
and “Particles” are available. They are different modules for visualizing the results.  
 
 For example, the velocity field can be easily understood by plotting the colors contours of the velocity. 
 
  



Right click on [Contour] → [Properties] 
 

 

 

Physical Value → [Velocity 
(magnitude)] 
 
Click on [Add] for 3 times 
 
[Face001] 
   Direction → J 
   Range → 
      J Min → 32 
 
[Face002] 
   Direction → J 
   Range → 
      J Min → 64 
 
[Face003] 
   Direction → J 
   Range → 
      J Min → 96 
 

 
The color bar can be adjusted by clicking on [Color Bar Setting] button on the former dialog. 
 

  

 

Orientation → [Horizontal] 
 
Number of labels → 8 
 
Width → 0.5 
 
Height → 0.1 
 
For X and Y, you can drag it by 
mouse to change the location 

  
 
The velocity contour appears as the following figure.  
 
 
 
 
 
 



  

 

 

 
 
The isosurface is suitable to visualizing the flow structures.  
 

Right click on [Isosurface] → [Properties] 
 

 

Physical Value →  [Coherent] 
 
Iso Value → 50 

 
After clicking on [OK], the isosurface of the turbulence coherent structures appears as the following figure. 
 

 

 

 



 
Right click on [Arrow] → [Properties] 
 

 

Uncheck [Auto] 
 
Standard value → 1 
 
Length on screen → 50 
 
Minimum value to draw → 0.01 
 
Sampling rate → 7 
 
Click on [Add] for 3 times 
 
[Face001] 
   Direction → J 
   J Min → 64 
 
[Face001] 
   Direction → J 
   J Min → 32 
 
[Face001] 
   Direction → J 
   J Min → 96 
 

 
After clicking on [OK], the velocity vectors appear as the following figure. Here, the velocity vectors are drawn 
together with [Face002] of the velocity contours to make the visualization more clear. However, a small 
overlapping happens between the velocity vectors and the velocity contour section. To avoid this, we draw 
here the velocity contour in level J = 65 replacing of level 64. 
 

  

 

 

  
 
You can also visualize the streamlines.  
 



Right click on [Streamlines] → [Properties] 
 

 

Range 
   I Min → 1 
   I Max → 1 
   J Min → 1 
   J Max → 129 
   K Min → 1 
   K Max → 36 
 
Generation space interval → 1/5 

 
After clicking on [OK], the streamlines appear as the following figure. 
 

  

 

 

 
It is also possible to visualize the motion of the flow by particles.  
 

  

 

Generation time interval → 1 
 
I Min → 1 
I Max → 2 
J Min → 1 
J Max → 129 
K Min → 1 
K Max → 65 
 
Generation space interval → 1 
 
Size → 3 
 



After clicking on [OK] and change the time step from the side bar, the following figure appear. 
 

  

 

 

 
You can also make movie from your results. As an example, particles tracing is a suitable choice to observe the 
trajectory of the flow. In order to generate a movie from your results, 
 

Select menu bar -> [File] -> [Continuous snapshot/Google Earth Export] 

 

 

 
The dialog for setting the snapshots and the animation will open. 

 

  

 

 



 
Specify the place for saving the files and the format of snapshot files. 

 

 

 

 

Specify whether you output the animation file of your result. 

 

 

 

 

Specify the start and end time for output of the snapshot files and the animation file. 

 

 

 



After setting all the properties, the dialog shown in left figure will appear. Click on [Finish], then the files 

will save the place you specified. The right figure shows the dialog which will appear during the output the 

files. 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


