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Introduction to Nays2DH 
 

You can use Nays2DH in the iRIC for your calculations using the following procedures; 

 

 

 

 

 

 

 

 

 

Generating the computational grid 

Generate the computational grid by using selected geographic data 

(river survey data, Digital Elevation Model,etc) 

Running a simulation 

Calculate with Nays2DH 

Visualizing the simulated results 

Visualize the simulated results such as flow velocity, water depth, river 

bed elevation and more using contour maps, vectors, etc 

Setting the computational conditions 

Set initial and boundary conditions, etc 

Launch Nays2DH 

Prepare to use Nays2DH in iRIC 
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TutorialⅠ. 

Calculation of flow and morphological change of 

river bed in a meandering channel 
 

 

⚫ Purpose of this tutorial 

 You can understand the basic operation of Nays2DH in iRIC by calculating the flow 

and morphological change of the river bed in a meandering channel with simple bed 

geometry, and also understand the fundamental bed evolution phenomena in a 

meandering channel. 
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1. Generate a computational grid 

 

 Generate a computational grid of a meandering channel with a rectangular cross 

section using the [Multi-function Grid Generator] included in iRIC. 

 

 

Select Menu bar → [Grid] → [Select Algorithm to Create Grid]. 

In the grid generation algorithm selection dialog, select [Multifunction Grid Generator] and 

press [OK]. 

 

 

 

The dialog for grid generation will be opened. 

You can generate the computational grid by clicking on [Create Grid] after setting the 

conditions defined as follows.  

 

[Channel Shape] 
-Select Channel Shape 

：Sine-generated curve 

[Cross Sectional Shape Parameters] 

 - Width：0.3m 

- Number of Grid in Lateral 

Direction：16 

[Channel Shape Parameters] 

 - Wave Length of Meander：4.7m 

- Meander Angle ：28.6° 

- Number of Grid in One Wave Length：
40 

[Bed and Channel Shape] 

 - Channel Shape：0.004 

 

The default values are used for the other 
parameters. 
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A confirmation dialog which asks you [Do you want to map geographic data to grid attributes 

now?] will appear. Click on [Yes], and the computational grid will be generated as follows. 

 

The computational grid will 

appear on the screen. 

 

2. Set the cell conditions 

 

 The cell conditions can be set on the generated computational grid. Here, you set the 

Manning’s roughness coefficient.  

 

Click on [Cell attributes] in the object browser, and change the status of cell attributes to  

. You can open the cell attributes by clicking on  bottom on the left side of [Cell attributes], 

and then click on [Manning’s roughness coefficient]. 

 

⚫ The left side of the figure is 

the object browser, and the 

right side of the figure is the 

visualization screen. 

 

⚫ When you want to change 

something in the 

visualization screen, you 

need to click on the related 
item in the object browser. 

When you click on that item, 

the background color of the 

item changes to light blue. 

Such status is defined as 

‘active’ here. 

 

⚫ While you keep the status of 

[Manning’s roughness 

coefficient] as , the 

contour on the grid 

indicates the value of 

[Manning’s roughness 
coefficient]. 
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Select all of computational grid by operating your mouse, and then right-click on the selected 

region. 

Then select [Edit value] on appeared menu. 

 

⚫ You can directly 

change the value of cell 

attributes of each cell. 

 

⚫ Hold down the Shift 

key and select cells 

continuously. You can 

select remote cells at 

the same time.  

 

 

 

On the dialog [Edit Manning’s roughness coefficient], you can specify the value of this 

coefficient in the region you selected.  

By this procedure, Manning’s roughness coefficient is set at all of cells in the grid. 

 

⚫ Manning’s roughness 

coefficient 

:0.013 
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3. Set the computational conditions 

 

 This section explains how to set the computational conditions for Nays2DH. The 

modified part of the dialog needed for this computation is only described below. For the 

rest of parameters, the default values are used. 

 

 

Select [Calculation conditions] → [Setting] on menu bar. 

 

⚫ [Import]: iRIC reads 

the computational 

conditions from another 

iRIC project file which 

was created using 

Nays2DH. 

 

⚫ [Export]: You can 

output the 

computational 
conditions for other 

runs. 

 

 

Set the computational conditions for this run as follows. 

 

⚫ Solver Type: setting the 

general settings of 

Nays2DH  
 

- Bed deformation: 

Enabled 

 

 

Note: You can select the 

items with mark [+], if you 

select [Advanced] in [Select 

Solver Type].  
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Set the boundary conditions.  

 

⚫ Boundary conditions 

 

-Periodic boundary 

condition: Enabled 

-Time unit of 
discharge/water surface 

file: Second 

 

 

After setting the conditions 

as shown below, click [Edit] 

for [Time series of discharge 

at upstream and water level 

at downstream]. 

 

 

 

Set the discharge of upstream end. 

 

⚫ Clicking on [Add] 

makes new line. 

 

⚫ Time from 0 to 1800 

(sec) with a constant 

discharge of 0.004 
m3/s, is given in this 

example. 
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Setting conditions related to Time. 

 

-Output time interval: 60 sec 
 

-Calculation time step: 0.01 sec 

 

-Start time of output: 0 sec 

 

Setting conditions related to Bed material. 

 

- Diameter of uniform bed 

material(mm): 0.55(mm) 
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4. Run a simulation 

 

 After setting calculation conditions, run the computation. 

 

For running a simulation, select [Simulation] → [Run] in menu bar or select  on menu tool 

bar. 

 

 

 

Before running the calculation, a message recommending that you save the current project is 

displayed, so click “Yes” to save the project. 

 

 

 

 

There are two methods of saving the project, [Save as File (*.ipro)] and [Save as Project]. 

Here, select [Save as File (*.ipro)] and save it. 
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When saving the project is completed, the solver console starts up and the calculation begins. 

 

⚫ The numbers shown in 

solver console are time 

(sec), discharge (m3/s) 

and downstream water 

level (m) (from left to   

right). 

 

⚫ The [out] shown on the 

right-hand side of the 

numbers means that iRIC 
has written the result to a 

file to be visualized. 

 

 

 

You can visualize the result after getting a dialog which informs you [The solver finished 

calculation] (left figure), or by selecting [Calculation result] → [Reload] on the menu bar 

(right figure) during the calculation.  
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5. Visualize the results 

 

 By visualizing the output results, we confirm the calculation result. 

 

Select [Calculation result] → [Open new 2D post-processing window] in the menu bar, or 

click on the button shown in the following figure. 

 

The buttons for visualization are 

from left to right:  

 

⚫ 2D Post-Processing 

window: for visualizing 

top or plan view of the 

result 
 

⚫ 2D Bird’s-Eye Post-

Processing window: for 

visualizing three 

dimensional view 

 

⚫ Graph window: for 

visualizing one 

dimensional graph of 

model variables 

 

 

2D post-processing window will open. 
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 To display the physical quantity in a contour plot, left-click on the quantity you want to 

visualize. We choose “ElevationChange (m)” to visualize the calculation result of bed 

evolution. 

 

⚫ [Scalar]: show a contour map of 

selected scalar data. 

 

⚫ [Arrow]: show a vector of selected 

vector data. 

 

⚫ [Particles]: visualize particle 

movement by selected vector data. 
 

⚫ [Particles]: visualize particle 

movement by selected vector data. 

 

⚫ [Cell attributes]: show the cell 

attributes you set in the cell 

conditions. 

 

⚫ [Measured values]: You can read the 

measured data such as experimental 

data. 

 

 

To change the range of color legend, right-click on [Scalar > ElevationChange (m)] and click 

[Property]. 

 

⚫ You can grab the color 

bar with the mouse and 

move it. (Note that the 

scalar must be active.) 

 

⚫ You can pan / zoom / 

rotate the drawing 

screen using the 

following mouse 

operation.  
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 You can change the maximum value, minimum value, division number, etc. of the color bar. 

 

⚫ Deselect [Automatic] 

 

⚫ Max: 0.02 (m) 

 
⚫ Min: -0.04(m) 

 

⚫ Deselect [Transparent] box 

 

⚫ Color bar setting: 

Direction > Horizontal 

 

 

 

 

 Now, you can clearly observe a point bar on the inner bend and the erosion in the outer bend. 
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 In the next step, the flow field is visualized by vectors. Click on the box of [Velocity] under 

[Arrow] in the object browser. 

 

The flow in the 

computation is 

visualized by vectors. 

However, the length 

of vectors is not 

suitable for the 

visualization. 

 

 

 

 For setting the properties of vectors, right-click on [Arrow], and select [Property] on the pop-

up menu that appears. The dialog for setting the vector scaling will open.  

 

⚫ Deselect [Auto] check box 

 

⚫ Length on screen: 20 pixel 

 

⚫ Legend title:  

    Velocity (m/s) 
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 By adjusting the length of vectors, you now can see the flow field in the meandering channel. 

 

 

 

 

 

 Next, the one-dimensional graphic function is used for visualizing the water level and bed 

elevation in the cross section. Select [Calculation Result] → [Open new graph window] 

on the menu bar. 
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 The dialog for setting the data of 1D graph will open. Select the X Axis as [J] and add 

[Elevation] and [WaterSurfaceElevation] from [Two dimensional data] to [Selected data]. 

 

⚫ X Axis: J 

 

⚫ Two-dimensional Data: 

Select [Elevation], 

[WaterSurfaceElevation] 

and click on [Add]. 

 

Note: I and J indicate the 

index of the longitudinal and 

transverse direction in the 
grid. 

 

 

 The water surface and bed in a cross section are visualized. Click on [Draw Setting] for 

changing the visualization properties of this graph.  

 

⚫ By moving the 

location of I on 

Controller, you can 

change the position 

of the cross section. 
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 You can change the style width and color of lines. 

 

⚫ Setting for Elevation(m)  

-Line style: Solid Line 

-Line Width: 3 

-Color: Black 

 

⚫ Setting for 

WaterSurfaceElevation(m) 

-Line style: Solid Line 

-Line Width: 3 
-Color: Blue 

 

 

 

 You can visually understand the line of water surface and river bed. 
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 As the last step, the simulated bed elevation changes are compared with the experimental 

results. Right-click on [Measured Values], and select [Import] on the pop-up menu. 

 

⚫ “measured.txt” is 

specified as a 

[Measured values]. 

 

 

 The measured data will be imported. Set the scalar and color bar ranges to be the same. 

 You can change the range of color legend by right-clicking [Scalar] under [Measured Values] 

and selecting [property] on appeared pop-up menu. 

 

⚫ The calculation 

result shows that 

the trend of 

measured values 

can be roughly 

reproduced. 
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You can do more qualitative comparison between simulated and measured bed topography. On 

the menu bar, select [Calculation Result] → [Open new verification window]. 

 

 

 

 

You will specify the time and quantity of simulated result for the comparison as well as the 

measured data. Here, the bed evolution is compared. 

 

⚫ [Timestep]: 1800, 

meaning you choose 

the simulation result at 

the end of computation. 

 

⚫ [Calculation Result]: 

ElevationChange(m) 
 

⚫ [Measured Value]: Dz 
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The dialog “Verification” will open. Select “Measured value vs. Calculation Result” for Chart 

type. The solid line in the figure means perfect agreement between simulated and measured 

bed evolution rate. The calculation result shows good agreement with the measured data. You 

can see how this agreement changes when you change the calculation condition (e.g., grid 

resolution, roughness, model parameters etc). 
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TutorialⅡ． 

Calculation of flow and bed morphological change 

of a real river 
 

 

⚫ Purpose 

 You will learn how to generate a computational grid from cross sectional river survey data, and 

set the computational conditions to calculate the flow and morphological changes in a real river. 

The computational results are visualized by the post-processing tools of iRIC. You will make a 

snapshot and animation of the computational results. 
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1. Generate a computational grid 

 

 A computational grid will be generated by using river survey data which includes the cross-

sectional geometry data for the river reach of interest. 

 

 

 You can import a river survey data by selecting Menu bar → [Geographic Data] → 

[Elevation(m)]. 

 

⚫ You will specify [I27-

35.riv] as a river 

survey data. 

 

 

 

 The dialog for setting the imported river survey data will open. 

 

⚫ Check on [Middle 

point of Low water 

way] for defining the 
location of centerline 

of the river survey 

data, and push [OK]. 

 

Note: you will see an error 

message when you open 

river survey data. You can 

just click “OK” to open the 

file. 
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 When reading is successful, the transverse survey data is drawn. 

 Next, a background image can be imported. Click [File > Property] on the menu bar. 

 

⚫ Please specify [I27-

35.jpg] as background 

image, or import the 

background images by 
following procedure.  

 

Background Images 

By importing background 

images such as maps and 

aerial photographs when 
creating a calculation grid or 

mesh, it is possible to create 

a calculation coordinate 

system that takes into 

consideration the levees, 

river banks, low waterways 

and high water reservoir 

boundaries. In addition, 

designation of vegetation 

cell, fixed bed cell, obstacle 

cell etc. can be set while 
referring to the background 

image, as is described below. 

 

Set the coordinate system of the imported data. Click [Coordinate System > Edit]. 

 

⚫ The coordinate 

system of the data 

read this time is 
[Orthogonal 

coordinate system 12 

series]. 
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The selection screen for the coordinate system is displayed. Enter “jgd” in the search window. 

Select “EPSG:2454 JGD2000 / Japan Plane Rectangular CS XII“ and click “OK”. 

Since you will return to the project property setting screen, please click “Close”. 

 

 

 

With the above settings, the coordinate system of the imported river survey data has been 

described. You can import background image from some sources like Google Map. 

 

Note: To show Google 

Map image correctly, you 

will need Google API key 

and set it into Menu bar > 

Option > Background 

Images (Internet). 
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Align the channel center line with the main channel of background image. 

 

⚫ By selecting the 

survey line and 

holding down the 

Shift key, bring it 

closer to the blue 

circle at the channel 

center point, you can 

move the center point 

with the mouse. 

 

 

 The channel center point was able to match the main channel center of background image. 
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 Set calculation grid generation conditions. 

 Select [Grid] → [Select Algorithm to Create Grid] on the menu bar as shown on the left. 

On the screen on the right, select [Create grid shape solving Poisson equation]. 

 
 

 

Click [OK] as it is. 

 

 

In this grid generation method, the calculation 

area is first set using the center line, the 

control section, and the left and right 
shoreline. 

 

You can also add the number of control 
sections later. 
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First, edit the center line with the mouse so that the center line passes approximately through 

the center of the main channel. 

If the number of vertices is insufficient, you can add using right click. 

 

 

 

 

Next, click [Build Left bank and Right bank line] from the right click menu. The screen for 

entering the distance from the center line is displayed. Please enter the approximate distance. 

For this case, both the left bank and the right bank are 300m. 
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There are some vertices on the left bank and right bank line. Move these vertices with the mouse 

to set the area to be calculated. 

 

Attention Point: 

The calculation area 

should be within the area 

of the imported river 
survey data. If you 

protrude from the area, 

the terrain data may not 

be mapped correctly to 

the calculation grid. 

 

Please keep in mind 

that the center line, the 

left bank line, and the 

right bank line are 

roughly perpendicular to 

the cross section near the 
upstream and 

downstream ends of the 

reach- this will aid in 

setting boundary 

conditions. 

 

 

 Once the calculation area is set, click [Create grid] from the right click menu. 
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The grid division number setting screen in the streamwise flow direction (ni) and transverse 

direction (nj) is displayed. 

Please set these as follows and click [OK]. 

Next, in the confirmation dialog that comes up, click the [Yes]. 

 

Note: For workshops, 
please set as following as 

a guide according to the 

specifications of the 

calculator. 

 

ni=50～ 

nj=20～ 

 

 A calculation grid was created. 

 

Please check the grid 

shape. In order to obtain 

better calculation results, 

it is important that grid 

lines are orthogonal as 

much as possible. 

 

Are the edges collapsed 

and there is some grid 

like a triangle?  
If so, check the points 

to be noted in the 

calculation area and 

correct the calculation 

area. 
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2. Setting cell attributes 

 

 Set the roughness coefficients for the fixed and movable bed by choosing a value of Manning 

coefficient as attributes of the cell. The low water channel is treated as a movable bed and the high-

water floodplain is a fixed bed; separate roughness coefficients are set for each.  

 

 Right-click [Geographic Data > Fixed or Movable Bed] of the object browser. Click [Import 

> Polygons] and load “floodplain.shp”. 

 

floodplain.shp 

 

In the polygon import setting screen, set the value to [Fixed bed] and click [OK]. 
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A polygon with “Fixed bed” attribute is loaded. 

 

 

 

 In the same operation, read the low waterway polygon “mainchannel.shp” as the value 

“Movable bed”. 
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 Copy the polygon because the place you want to set Manning’s roughness coefficient is the 

same as fixed bed and movable bed part. Right-click on the polygon you want to copy and 

select [Copy]. 

 

 

 

 Select the geographic information to copy the selected polygon. 

 

⚫ Select [Manning’s 

roughness coefficient] 

 

Set the value of the polygon to be copied. 

This operation is performed on both the high-water bed and low-water channel polygons. 

 

⚫ Polygon with specified 

low waterway: roughness 

coefficient 0.022 

 

⚫ Polygon with specified a 

high waterbed: roughness 
coefficient 0.04 
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 At this stage, the cell attribute has not yet been reflected in the calculation grid. To map a 

cell attribute to a calculation grid, select [Grid > Attributes Mapping > Execute] on the 

menu bar. 

 

 

 

 If you check the cell attributes of the grid, you can see that the cell attribute is mapped in the 

calculation grid. 

 

⚫ If you want to fine-tune 

after mapping, you can 

change the value by 

specifying it in cell units. 
 

⚫ However, it is important 

to note that if you change 

the cell attributes directly 

on a cell-by-cell basis 

and then perform the 

mapping again, the 

directly modified part 

will disappear. 
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3. Setting calculation conditions 

 

 Set the calculation conditions. Since only the changes are described, you can infer the settings that 

are not explained here as the default values. 

 

Set the necessary calculation conditions. 

 

⚫ Solver type: setting the 

general settings of Nays2DH 

 
-Bed deformation: Enabled 

 

 

 

Set the boundary condition. 

 

⚫ Boundary Condition 

 

- Time unit of 

discharge/water surface file: 
Hour 
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Set the discharge of upstream end. 

 

⚫ For flow setting, click 

[Import] and load 

“qt.txt”. 

 

 

 

Setting conditions related to Time. 

 

⚫ Output time interval: 

200 (sec) 

 

⚫ Calculation time step: 
0.5 (sec) 

 

⚫ Start time of output: 0 

(sec) 

 

⚫ Start Time of bed 

deformation: 3600 

(sec) 

 

 

 

 

 

 

 



   

37 

Nays2DH Tutorial 

Setting conditions related to Bed material. 

 

⚫ Diameter of uniform 

bed material: 0.4 (mm) 
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4. Run a simulation 

 

Select [Simulation] → [Run] in menu bar . 

 

 

 

5. Visualization and out output of calculation results 

 

 Output the calculation result in iRIC and output the image. 

 

Select [Calculation result] → [Open new visualization window (2D)] on the menu bar. 

 

⚫ Output example 

displaying background 

image and water depth 

contours 
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Fix the color range of the contour so that it does not visualize low water depths. 

Right-click [Scalar > Depth (m)] in the object browser and select [Property]. 

 

⚫ Deselect [Automatic] 

 

⚫ Max: 15 m 
 

⚫ Min: 0.05 m 

 

⚫ Deselect [Fill lower area] 

 

⚫ Deselect [Transparent] 

 

 

 

Next, visualize the arrow. 

Select [Arrow > Velocity (ms-1)] in the object browser. 
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By right clicking on [Arrow > Velocity (ms-1)], you can set some parameters for visualizing the vector. 

Below is an example. 

 

 

 

 

Use the animation tool bar to check the calculation result. 
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Also you can draw the hydrograph at the same time. 

Select [Calculation Result > Open new Graph Window] in the menu bar. 

 

⚫  X Axis: Time 

 

⚫  Select [Discharge (m3s-1)] in 

point data and select [Add]. 

 

 

 

 

 

You can draw a contour map and a hydrograph at the same time. 

The computational results can be outputted as image file. Select [File > Continuous Snapshot 

/Movie/ Google Earth Export] on the menu bar.  
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Make the necessary settings in the continuous snapshot wizard. 

 

⚫ Target windows: Select 

both 

 

⚫ Output file: In one file 

 

⚫ Layout: As is 

 

 

Specify the file output location and image file format. 

 

⚫ Specify directory 

 

⚫ File Format: jpg 
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Specify whether to output movie． 

 

⚫ Output the movie files 

 

 

 

Specify the start and end time to output. 
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You can also export the image file into Google Earth 

 

 

 

 

 

When the setting is completed, a confirmation screen (left figure) appears, so select [Finish]. 

The screen on the right is the output screen. 
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Image files grouped with a contour diagram and hydrograph in the movie are output. 

 

 

 

 

An example of the Google Earth export of the computational result 

 

 

 


